Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Laptop fps problem (stuck at 30)
#1
Lappy specs:

Processor: Intel® Core™ i7-3610QM CPU @ 2.30GHz (8 CPUs), ~2.3GHz
Memory: 16384MB RAM
OS: Windows 7 home premium
Video: NVIDIA GeForce GX 680m


Problem is, I cannot get the frame rate above 31.60

I have fiddled with every single configuration: some will slow the game's fps down, but none gets it above 31.

I only have FF12 at the moment.


Suggestions?

EDIT: The fps starts a 60 and stays there upon loading the game, but once the game starts, drops from 60 right to 30 (not 60, 45, 38 > straight 60 to 30)
Reply

Sponsored links

#2
check vsync settings in emu and in nvidea control pannel, turn them off should do the trick
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#3
(10-26-2012, 06:02 PM)WarWeeny Wrote: check vsync settings in nvidea control pannel, turn them off

Done.

(10-26-2012, 06:02 PM)WarWeeny Wrote: check vsync settings in emu control pannel

Where is this? in pcsx2 configurations?
Reply
#4
(10-26-2012, 05:59 PM)Ariestr Wrote: Lappy specs:

Processor: Intel® Core™ i7-3610QM CPU @ 2.30GHz (8 CPUs), ~2.3GHz
Memory: 16384MB RAM
OS: Windows 7 home premium
Video: NVIDIA GeForce GX 680m


Problem is, I cannot get the frame rate above 31.60

I have fiddled with every single configuration: some will slow the game's fps down, but none gets it above 31.

I only have FF12 at the moment.


Suggestions?

EDIT: The fps starts a 60 and stays there upon loading the game, but once the game starts, drops from 60 right to 30 (not 60, 45, 38 > straight 60 to 30)

That game should not pose too much problem. Still the number of cores and threads don't help that much PCSX2 which uses at max 3 to date.

When entering the actual game the demand is much greater so the slowdown for the CPU speed is not high enough. You may start increasing VU cycle stealing to the second notch and observing the difference, this game accepts it fine. Maybe you need to increase one step EE but probably will be unnecessary.

One final word, Intel CPUs, mainly those at notebooks have issues with the power options. You may want to put Windows in a performance power plan while playing. Try this if the above tweak fails. Just remember to return to the original power plan to spare battery usage.

PS: A final final word (hopefully), that sudden drop in FPS may mean you have VSync on, you should consider leaving the global setting in Nvidia contral panel in "adaptive" for that Vertical sync, usually the last setting there.
Imagination is where we are truly real
Reply
#5
(10-26-2012, 06:07 PM)Ariestr Wrote: Done.


Where is this? in pcsx2 configurations?

emualtion options >> gs window

there you can find this option

report back with results Smile
------------------------
status:
------------------------
trolling mode: ACTIVE!
Reply
#6
(10-26-2012, 06:07 PM)nosisab Ken Keleh Wrote: You may start increasing VU cycle stealing to the second notch and observing the difference, this game accepts it fine. Maybe you need to increase one step EE but probably will be unnecessary.

No increase in fps using any of the options.

(10-26-2012, 06:07 PM)nosisab Ken Keleh Wrote: One final word, Intel CPUs, mainly those at notebooks have issues with the power options. You may want to put Windows in a performance power plan while playing. Try this if the above tweak fails. Just remember to return to the original power plan to spare battery usage.

Checking into this.

(10-26-2012, 06:08 PM)WarWeeny Wrote: report back with results Smile

No effect for both. Game still at 30-31 fps
Reply
#7
Wait, no increase in FPS when acting on the VU slider?

that's very odd, please post screenshots of your emulator's configuration so we can try to understand what is happening in there.

Make sure Vsync is not "On" in Nvidia control panel, it overrides the game's definition. Put it in adaptive so it will clamp the FPS at 60hz but disables itself if the FPS falls down.
Imagination is where we are truly real
Reply
#8
(10-26-2012, 06:07 PM)nosisab Ken Keleh Wrote: You may want to put Windows in a performance power plan while playing.

Bingo. Changed settings to high performance and I now have 60 fps.

Thanks bunches!

EDIT:

(10-26-2012, 06:18 PM)nosisab Ken Keleh Wrote: Wait, no increase in FPS when acting on the VU slider?

that's very odd, please post screenshots of your emulator's configuration so we can try to understand what is happening in there.

Using default config.



Also: Is there a way to edit my thread title to [Solved] or something?
Reply




Users browsing this thread: 1 Guest(s)