Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Legaia 2: Duel Saga
#1
I've been trying to get this game to work correctly on my machine for a bit and I think I found some good settings to use. This game runs very slow at times and none of the speed hacks seem to do anything to help. However, I've found that it is the sound that slows it down. Specifically the sound stretching. Disabling it stops any slowdowns, but it makes the sound skip like crazy. The best compromise I've found is to go into the settings of the sound stretching and turn all the settings to the highest. It still slows down once in a while, but not nearly as bad, and the sound still seems to have a glitch here and there, but it's almost perfect. You can have the resolution be your full desktop resolution (even the internal one), and have the best interlacing option (even the 1/2 fps ones).
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply

Sponsored links

#2
That's interesting because stretching should be a little slower but not enough to cause slowdowns, did you try other sound plugins? Do you have other speedhacks enabled by any chance?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
1 - what is your machine? (processor, vid card os etc etc)

2 - wich version are you using? (pcsx2)

3 - .... where you having problems with this game or did you just post how you run the game? Tongue
Reply
#4
Soundtouch (the stretching) makes for an overhead of maybe 0.4% cpu load.
It will not make a game slower.
However the stretched, molasses like audio makes it seem very slow.
Reply
#5
that game is optimise via DX10 renderer if you have a DX10 video card i could reached at normal fps in addition try set clamp settings to none(Config---->Advanced)
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#6
(05-17-2010, 09:30 PM)Shadow Lady Wrote: That's interesting because stretching should be a little slower but not enough to cause slowdowns, did you try other sound plugins? Do you have other speedhacks enabled by any chance?
I haven't tried other sound plugins, but I tried all the other speedhacks and they made little to no difference.

(05-17-2010, 09:31 PM)warWeeny Wrote: 1 - what is your machine? (processor, vid card os etc etc)

2 - wich version are you using? (pcsx2)

3 - .... where you having problems with this game or did you just post how you run the game? Tongue
1.
Processor: AMD Phenom II X4 2.80 GHz
RAM: 4 GB
Video Card: ATI Radeon HD 4870 (2 GB)
OS: Windows 7 Pro
Also, Windows 7 gives me a 7.2 for CPU, 7.3 for RAM, and 7.4 for both Aero and gaming graphics.

2. Version r1888

3. I was, but I was posting this on how to get it running smoothly.

(05-18-2010, 01:15 AM)rama Wrote: Soundtouch (the stretching) makes for an overhead of maybe 0.4% cpu load.
It will not make a game slower.
However the stretched, molasses like audio makes it seem very slow.
I don't know, but it's not just the sound. The dialog, the people moving, controlling the character around...during the slowdowns, the whole game goes super slow. When I turned off the stretching, the music glitched a bunch but there were no slowdowns at all.

(05-18-2010, 01:35 AM)tallbender Wrote: that game is optimise via DX10 renderer if you have a DX10 video card i could reached at normal fps in addition try set clamp settings to none(Config---->Advanced)
I'm using DX11 (tried DX10 as well). I'll mess with the clamp settings and see.

EDIT: Clamp is already none.
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply
#7
Look at your FPS. They measure how fast the game runs. You'll see that soundtouch doesn't make a difference there.
Reply
#8
(05-18-2010, 04:44 PM)rama Wrote: Look at your FPS. They measure how fast the game runs. You'll see that soundtouch doesn't make a difference there.
'kay, I'll try that.

(05-17-2010, 09:30 PM)Shadow Lady Wrote: That's interesting because stretching should be a little slower but not enough to cause slowdowns, did you try other sound plugins? Do you have other speedhacks enabled by any chance?
I tried the ZeroSPU2 one instead and while it had cracks in the sound and some of the sounds sounded like my speakers were blown, there were no slowdowns at all.
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply
#9
Okay, so I tested all 3 sound plugins and different settings for them (including the ones that I said sped up the game) and there actually are slowdowns still. I was just testing my settings during a part where it doesn't slow down. When I tested the first town, it still had slowdowns no matter what I set (even native resolutions). It goes down to 60-70% FPS during some parts. But, like rama said, it wasn't due to the sound stretching. The sound stretching just made it evident.
OS: Windows 7 Professional
CPU: AMD Phenom II X3 720 2.8GHz @ 3.5GHz
RAM: 4GB Corsair DDR2 800MHz
GPU: SAPPHIRE Radeon HD 4870 1GB

MBTI: INTP
Enneagram: 9w1 or 5w4...I can't decide.
Reply
#10
there are slowdowns in every game, almost depending on your cpu. 2,8ghz maybe its good but around an intel "i" series 3,5ghz is recommended to be able to play almost everything, and in some very demanding cpu scenes its natural u will have slowdowns that u can only make them be a little better with speedhacks Tongue
OS: Win 7 Ultimate x64 sp1, MoBo: Asus P5QD Turbo, CPU: Q6600 @ 3,0Ghz, RAM: Trancend 2x2gb 6-6-6-18 800 MHz, GPU: HD 4850 1gb.
Pcsx2: Always Latest
Reply




Users browsing this thread: 1 Guest(s)