Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LibUSB (MotionJoy?) problems
#1
This isn't directly connected to the PCSX2, but a problem I've been having. When I thought of where to ask, you guys came to mind right away, so I finally registered myself and here I am.

Anyway, I'll give some background. For some time, the LibUSB thingie that I use to enable my PS3's controller to be able to play on emulators hasn't really worked as it should. I was able to map the buttons to a PSX emulator (ePSXe), because there you can hold onto a button, then select the next button option, then change it, and so on and so on, without any other "button presses" disturbing you.

The problem first manifested itself there. Whenever I clicked a button to assign, it kept giving me something like...what was it...L_RIGHT? Something like that. Either way, it's the left stick, I think.

So I still, to this day, haven't assigned the Axises (Axii?) to that emulator, and use the D-Pad (but considering how great the DualShock's D-Pad is, that isn't really very bad).

But on PCSX2, I need to use the sticks, but I'm not able to assign them. Currently, through my doo-hickying, and trying Kingdom Hearts, the left stick only work left and right (so Sora can only run left and right), and he keeps running around even when I'm not pressing any buttons (which I suspect has something to do with the SixAxis motion control thingamajig).

Oh, and one thing that I think really matters concerning this: these problems started appearing after I got and installed Windows 7. Could this be the problem? And if so, are there any other similar programs that ARE compatible with Windows 7 (providing this LibUSB thing isn't)?

tl;dr - Program that allows the me to use the PS3 DualShock to play games hinders me from configuring/assigning the Axis...things (the sticks), and seemingly the SixAxis motion control seems to take over what the sticks are SUPPOSE to do.
Reply

Sponsored links

#2
Try to configure your MotionJoy settings (it has settings, right?),
so the SixAxis controls are mapped to nothing / disabled.
Also try increasing the dead zone of any analogue axis.
Reply
#3
I just came here to say, "Thanks, rama."

I didn't follow quite your instructions, but the "Try to configure yout MotionJoy settings" led me to just go and calibrate the controller under the settings window Windows' Control Panel gave me.

I calibrated it, and it's working perfectly now.

Problem solved.
Reply




Users browsing this thread: 1 Guest(s)