Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux 0.9.7
#1
I realize beta's aren't supported, but I suspect this is an easy fix:

Quote:adam@adam-desktop:~/emulation/pcsx2$ ./pcsx2
./pcsx2: error while loading shared libraries: libwx_gtk2u_adv-2.8.so.0: cannot open shared object file: No such file or directory

This is even after:

Quote:sudo apt-get install python-wxgtk2.8 python-wxtools wx2.8-i18n

Quote:adam@adam-desktop:~$ ls -l /usr/bin/wx*
lrwxrwxrwx 1 root root 27 2010-07-07 14:31 /usr/bin/wx-config -> /etc/alternatives/wx-config

Any help would be awesome!
Reply

Sponsored links

#2
Install all libs listed on this post and you should be fine: http://forums.pcsx2.net/Thread-PCSX2-Lin...#pid115759 (specialy this part http://wiki.wxpython.org/InstallingOnUbuntuOrDebian ).
Athlon II x2 245 (@3.6Ghz), 6gb DDR3 1333, GeForce GTS250 2gb Ram, Linux Mint 12 32bit.
Reply
#3
A tips (work on debian not sure about derivative distribution): apt-file
# apt-get install apt-file
# apt-file update
# apt-file search libwx_gtk2u_adv-2.8.so

# it returns the package name with the file matching, in my system:
libwxgtk2.8-0: /usr/lib/libwx_gtk2u_adv-2.8.so.0
libwxgtk2.8-0: /usr/lib/libwx_gtk2u_adv-2.8.so.0.6.0
libwxgtk2.8-dev: /usr/lib/libwx_gtk2u_adv-2.8.so


And one others possibility is a missing symlink, ls -l /usr/lib/libwx_gtk2u_adv-2.8*. If it is only miss the *.so.0 just add a symlink to the library.

Edit: FYI this package are useless: python-wxgtk2.8 python-wxtools. We do not have any python code on pcsx2 Wink
Reply




Users browsing this thread: 1 Guest(s)