Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Linux Mint 17.1 (x64) Issue
#1
I'm having an issue with trying to install PCSX2 on Linux Mint 17 via PPA (I've tried both Experimental and Stable), and when I go to install it, it tells me it's going to remove cinnamon and a bunch of other essential files!
[Image: 5e537dcf3c48a542ab2cbf4aa5df3a69.png]

I've tried the tar package, and I couldn't get that working either, I got this error when I tried it using the terminal.
Quote:ERROR the plugin (plugins/libzzogl-0.4.0.so) miss some dependencies
libCg.so => not found
libCgGL.so => not found
libwx_baseu-2.8.so.0 => not found
libwx_gtk2u_core-2.8.so.0 => not found
libwx_gtk2u_adv-2.8.so.0 => not found

ERROR the plugin (plugins/libGSdx-0.1.16.so) miss some dependencies
libEGL.so.1 => not found

ERROR the plugin (plugins/libspu2x-2.0.0.so) miss some dependencies
libportaudio.so.2 => not found
libSoundTouch.so.0 => not found
libwx_baseu-2.8.so.0 => not found
libwx_gtk2u_core-2.8.so.0 => not found
libwx_gtk2u_adv-2.8.so.0 => not found

./pcsx2: error while loading shared libraries: libwx_baseu-2.8.so.0: cannot open shared object file: No such file or directory

Is there anyway to get this working on Linux Mint, preferably by PPA?
Reply

Sponsored links

#2
I take it you have the repository added? Did you sudo apt-get update? If so, try this. Just a hunch, but in the past sometimes this worked and sometimes it didn't... sudo apt-get build-dep pcsx2-unstable .. then sudo apt-get install pcsx2-unstable:i386 .

If it still wants to remove half your system, then Ubuntu multiarch truly has made garbage progress over the last 3 years like I thought. You could try 32bit with PAE kernel or go to a distro with proper multilib ability, like Antergos (based on Arch). Or wait for Gregory to chime in about the PPA. Tongue
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#3
(01-13-2015, 03:13 AM)DaTankAC Wrote: I take it you have the repository added? Did you sudo apt-get update? If so, try this. Just a hunch, but in the past sometimes this worked and sometimes it didn't... sudo apt-get build-dep pcsx2-unstable .. then sudo apt-get install pcsx2-unstable:i386 .
Yes, Yes, and I've tried both on my main PC, and it wanted to delete half of my system...

Strange thing, though, I just tried the last command on my laptop (which also uses Mint 17.1 x64), and it installed without deleting anything, bizzare.

EDIT: I tried the same command again on my main PC, and I got this error:
Quote:Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
pcsx2-unstable:i386 : Depends: libsdl2-2.0-0:i386 (>= 2.0.0) but it is not going to be installed
N: Ignoring file 'getdeb.list.bck' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'getdeb.list.bck' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
E: Unable to correct problems, you have held broken packages.

(01-13-2015, 03:13 AM)DaTankAC Wrote: If it still wants to remove half your system, then Ubuntu multiarch truly has made garbage progress over the last 3 years like I thought. You could try 32bit with PAE kernel or go to a distro with proper multilib ability, like Antergos (based on Arch). Or wait for Gregory to chime in about the PPA. Tongue
I'd rather stick with Linux Mint if that's alright, I love the cinnamon interface and Ubuntu (+Ubuntu-based, like Mint) seems to be the most supported Linux OS, and therefore has the most packages available, right?
Reply
#4
Okay, I managed to install it, but when I try it out, I get this error:
[Image: PCSX2Message_002_zpse1ff5769.png]

EDIT:... and my desktop got all messed up after installing it, luckily, I had restore points, but is there anyway to avoid this happening again? It never said anything about deleting any packes that time, though...
Reply
#5
Likely the GPU driver is wrongly installed (for 32bits operation). And potentially SDL2 is not multiarch capable (or one dependency).
You can check it
Quote:apt-cache show libsdl2-2.0-0 | grep "Multi-Arch:"
Reply
#6
I typed the command in, and got this back...
Quote:Multi-Arch: same
Multi-Arch: same
I got it twice, and I have no idea what "same" is supposed to mean...
Reply
#7
same means that you can install both amd64 and i386 in the same time. It could be a dependency that is not multiarch aware.
Reply
#8
So what can/do I do?
Reply
#9
try the new PPA version that depends on SDL1.
Reply
#10
Okay... Where do I find it? Is it on the launchpad page?
Reply




Users browsing this thread: 1 Guest(s)