Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Logitech F310 not working in game
#1
I set up all my stuff and plugins to use this gamepad, but it is not working. I was trying to play Shadow of the Colossus, but I could not navigate the main menu. I set up some key bindings for my keyboard as well and that seemed to work, but I would prefer to use my gamepad.

These are the gamepad key bindings:
http://i.imgur.com/ksgGtCV.jpg

And these are the settings for the plugin:
http://i.imgur.com/VYMffwz.jpg

I also clicked the "test device" and all the buttons were working.
Please help! Thanks so much!
Reply

Sponsored links

#2
You may want trying to disable direct input at the Game devices API. Try disabling the mouse API also unless strictly necessary using it with the emulator.

At the pad1 tab you should have all keys associated with XInput. I can't say how that DX controller is affecting the gamepad.

Edit: Looking at your gamepad specs, it has a key to work either with DInput or XInput, chose in the emulator according to what you have in the actual controller, not both. Possibly XInput.
Imagination is where we are truly real
Reply
#3
(02-27-2014, 05:12 AM)nosisab Ken Keleh Wrote: You may want trying to disable direct input at the Game devices API. Try disabling the mouse API also unless strictly necessary using it with the emulator.

At the pad1 tab you should have all keys associated with XInput. I can't say how that DX controller is affecting the gamepad.

Edit: Looking at your gamepad specs, it has a key to work either with DInput or XInput, chose in the emulator according to what you have in the actual controller, not both. Possibly XInput.

thanks for the info. I tried both direct input and Xinput made key bindings for both. tested it. but ingame. it does not seem to work. and it is rather annoying because i have to keep watching that long opening cutscene before the menu.
Reply
#4
(02-28-2014, 02:37 AM)MrWaterboat Wrote: thanks for the info. I tried both direct input and Xinput made key bindings for both. tested it. but ingame. it does not seem to work. and it is rather annoying because i have to keep watching that long opening cutscene before the menu.

I tested with my own razer onza activating the DInput and the DX appeared here also while reconfiguring the keys and misworked.

Assuming there is not other differences you might want to disable DInput at the gamepad API and remake the whole key rebind from scratch.

All keys should be associated with XInput pad0.

Alternatively you may want to try DInput and put your Logitech controller in this mode as well (to this disable/untick XInput at the API).

Edit: despite your statement of having done all this, something is still wrong where there is no apparent reason to it. maybe you should delete the Lilypad.ini from the /inis folder and restart from the very start.
Imagination is where we are truly real
Reply
#5
Try mapping the "analog" button somewhere and pressing that.
Broken d-pad and analogues are a sign of the pad state being digital (and the ps2 can't handle that. It expects analog.)
Reply
#6
So I tested it on another ISO and it worked perfectly. (except for one crash). It might have just been the SotC ISO that I got.
Reply
#7
Unlikely.
Reply




Users browsing this thread: 1 Guest(s)