Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Looking for some mymc help
#1
Hi folks. I'm trying to get mymc-gui to run on my Windows 7 64-bit PC and I get the following error message:

C:\mymc\mymc-gui.exe: error: Incorrect number of arguments.
Usage: C:\mymc\mymc-gui.exe [-ih] memcard.ps2 command [...]

Is anyone familiar with this error and can you walk me through how to fix it, please?

I unpacked the latest mymc download into a mymc folder (shown in the error message above) as the README file instructs. I also initially got the .dll errors I've seen documented, but I've corrected those. Just can't figure out how to get past this error message.

Thanks for the help!
Reply
#2
did you install directx9 on the machine? it is needed

when u press enter on mymc-gui you should get a screen in which you are asked to select a memory card

try downloading MyMc alpha 2.6

maybe the one u are using doesn't work on your machine
Reply
#3
(11-06-2012, 04:12 PM)solidus Wrote: did you install directx9 on the machine? it is needed

when u press enter on mymc-gui you should get a screen in which you are asked to select a memory card

try downloading MyMc alpha 2.6

maybe the one u are using doesn't work on your machine

Yes, I have the latest directx on my laptop (directx11, which as I understand, includes all previous versions). I'm also using the mymc alpha 2.6. Still no luck.

Does it matter where I've installed mymc or where the PCSX2 Memory Card folders are located? Mymc is in the root C:\ directory, and PCSX2 Memory Card folders are under the Documents directory.

Thanks.
Reply
#4
http://forums.pcsx2.net/Thread-Mymc
http://www.addictivetips.com/windows-tip...windows-7/
Reply
#5
maybe MyMc has an issue with your windows

try it in compatibility mode
Reply
#6
(11-06-2012, 06:19 PM)solidus Wrote: maybe MyMc has an issue with your windows

try it in compatibility mode

Thanks, I just tried this and I get the same error. I can't be the only person trying to run mymc on Windows 7 64-bit, can I?

Vsub, thanks for the links. I've inserted the required .dll files in the correct locations (both in the Windows/SysWow64 folder as well as the mymc folder), but still no go.

Oh well, guess I'll just look into transferring saves back and forth between my PC and PS2 another way.

Thanks again for trying folks!
Reply
#7
Try placing them in the mymc directory(remove those that you placed in Windows/SysWow64)
Reply
#8
Runs just fine for me on Win7 x64, but does require elevated privileges. IIRC I had to set that manually, but I might be wrong, and the error message when running it as user is different here anyway - but I figure it's worth a mention.
Reply
#9
(11-06-2012, 10:33 PM)vsub Wrote: Try placing them in the mymc directory(remove those that you placed in Windows/SysWow64)

Tried that as well. Still won't open.

Eloris, I've tried running it as an administrator. Same error.

When I get time, I'll try to uninstall/reinstall both PCSX2 and mymc and see if that helps.

Keep the suggestions coming if you have them. I appreciate the troubleshooting assistance!
Reply
#10
i am using win 7 enterprise 64 bit and it is working for me

i am unsure what you can do. try using MyMc on another machine
Reply




Users browsing this thread: 1 Guest(s)