Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
LotR Third Age Sound Lag
#1
Hopefully, this hasn't already been answered somewhere else. Stats in the code.

As the title suggests, I'm trying to play one of my favorites. After several hours learning how PCSX2 works and experimenting, I can't seem to get anywhere.

With everything on default, cutscenes run at 70ish FPS and the game runs at 25-50. The sound stayed in perfect sync, which is to say it was as messed up as the video, both too fast in cutscenes and drawn out in-game.

With settings I've detailed below, the game runs at 60 FPS in cutscenes and between 50-60 in game, with occasional dips as low as 45. However, the sound is behind the video. For those familiar with the game, the opening scene has an elf speaking after a ring wraith; his voice is still playing after she is on screen and should have spoken almost a full sentence.

I messed with sound latency, to no avail. Messed with different sync modes and advanced sync settings, to no avail. Anyone have suggestions?

Code:
PCSX2 5350, downloaded yesterday.
Standard plugins except for TwinPad 0.8.3
Win 7 64 bit, i5 dual core 2.4GHz, ATI Radeon HD 5145 w/ 1GB VRAM, 8GB RAM, ASUS laptop
Settings: Clamping Mode none (both cases), FPS limiter enabled and set to 59.94 in the ini, widescreen 1280x800, MTVU enabled, EE cyclerate 3, VU stealing 3, GSDX SSE41, D10 Hardware render, HW hacks enabled with 8x aliasing and WildArmsOffset. All other settings default.

PS: Without some combination of EE and VU enabled, the game is too slow. I can turn either down and get similar FPS, but even with AA off I cannot have them both on defaults. I thought turning EE to 1 would fix it, but sound lagged just as much.
Reply

Sponsored links

#2
that laptop won't help since it's only 2.4Ghz and that video card is a early-entry class video card making it too weak to run as well.
not best for running pcsx2,if you have a desktop w/ 3ghz and an mid-range video card it will be a different story.
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
(09-05-2013, 04:41 AM)smartstrike Wrote: that laptop won't help since it's only 2.4Ghz and that video card is a early-entry class video card making it too weak to run as well.
not best for running pcsx2,if you have a desktop w/ 3ghz and an mid-range video card it will be a different story.
I have better, but that defeats the purpose. If I'm playing a PS2 game on a desktop, why not just play it on the PS2 sitting across the room? The laptop was supposed to bring mobility to the game. For moments like this, sitting in a hotel room.

Can't afford a new lappy right now, can't upgrade it, so... yeah.
Reply
#4
So, if you remove any hacks and return the default settings, the sound doesnt lag, but it is too slow to play?

Also are you using any cheats?
Cooler Master HAF X Full Tower
ASRock Z97 Extreme4
EVGA GeForce GTX 970 4GB
EVGA SuperNOVA 850W
Intel Core i5-4690K - OC'ed to 4.5GHz
G.SKILL Ripjaws X 8GB DDR3 1600
CORSAIR Hydro H105
Indigo Xtreme 115X-XS Metallic TIM
Windows 7 SP1 64-bit
PCSX2 1.4.0 unless otherwise specified
Reply
#5
(09-05-2013, 03:57 PM)jlwmanagement Wrote: So, if you remove any hacks and return the default settings, the sound doesnt lag, but it is too slow to play?

Also are you using any cheats?
You are correct. Why it syncs properly with defaults but incorrectly with speed hacks, I don't know. I don't really understand everything the hacks are doing and how it fits together; makes it hard to troubleshoot when all I can do is guess.

No cheats enabled. To my knowledge, there are none already prepared for the game, and I haven't bothered figuring out how to make my own.
Reply
#6
Speed hacks are just that and they can break things. If it works but just isnt fast enough then the only thing you will be able to do (to my knowledge) is to try each speed hack one at a time and see which one (or combo) causes the issue so you can get as much performance as possible but still have the synched audio.

Unfortunately there isnt anything useful on the compat list.
Cooler Master HAF X Full Tower
ASRock Z97 Extreme4
EVGA GeForce GTX 970 4GB
EVGA SuperNOVA 850W
Intel Core i5-4690K - OC'ed to 4.5GHz
G.SKILL Ripjaws X 8GB DDR3 1600
CORSAIR Hydro H105
Indigo Xtreme 115X-XS Metallic TIM
Windows 7 SP1 64-bit
PCSX2 1.4.0 unless otherwise specified
Reply
#7
(09-05-2013, 08:56 PM)jlwmanagement Wrote: Speed hacks are just that and they can break things. If it works but just isnt fast enough then the only thing you will be able to do (to my knowledge) is to try each speed hack one at a time and see which one (or combo) causes the issue so you can get as much performance as possible but still have the synched audio.

Unfortunately there isnt anything useful on the compat list.
I'll try it later tonight. I had more speed hacks than necessary so I could run 8x AA, but if I lower or disable the AA I might find a combination of hacks that keep audio in sync.
Reply
#8
So... I returned everything to default values, and it still didn't match the audio up correctly. The only thing I didn't reset was the TwinPad plugin. Unless that messed with my sound somehow, I don't know how it was working correctly before yet won't work now.

Tinkering more with the sound options, I used the second option and dropped the latency as far as it would go. That actually made the sound go too fast (and clip terribly). I thought I was on to something, but increasing latency until it stopped clipping (around 6mls) dropped sound back behind video again; apparently it was the clipping that made it speed up.

Any ideas?
Reply
#9
Are you using iso or dvd ?
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#10
(09-06-2013, 05:30 PM)Brock lessner Wrote: Are you using iso or dvd ?
ISO. The beginner's guide said it was faster.
Reply




Users browsing this thread: 1 Guest(s)