Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Lots of problems with Drakengard
#1
I've searched the forums for this and found some related things, but they were having slightly different problems. In my case, in hardware mode the movies run at 50fps (PAL version), but the main menu is 20fps and things like the map and the opening monologue is a pitiful 5fps. Putting it into software mode keeps it at 50fps, though unfortunately looking blurry as hell. Those issues pale into comparison to the main one; the main character is invisible! It's not rendering him at all, though it is rendering the dust clouds that he kicks up as he moves around.

I have PCSX2 0.9.8 on Windows 7 64-bit running on a Phenom X4 955 BE 3.2ghz, 4GB DDR3 RAM and an ATI HD5860. The GS plugin is GSdx 4600 SSE2 0.1.16 and the SPU2 (if that matters) is SPU2-X r4600m 1.4.0. I'm running the game from an ISO.

Sponsored links

#2
For the speed issue you could try the skipdraw hack (read the guide to find out how).
For the missing character, try the EE timing hack under gamefixes.
#3
Unfortunately neither of those things made a difference. I also noticed that it isn't just the main character not getting rendered, it's all the enemies too. This is one game I might just play on my actual PS2 since PCSX2 doesn't really seem to make it look much nicer even when on x3 resolution (then again, I'm just going off the ground and the odd structure since I can't see the people).

Edit
Well I just tried out the latest build, the one released 11 hours ago, and now all characters appear. The framerate issues persist, though. It seems to be when large 2D elements are on-screen. The health bar and other things are okay, but when you're looking at a menu, the map or even bring on the weapon select wheel, the framerate takes a massive hit. After that happens a few times the framerate becomes generally unstable and the game speed is about 60% with spluttering sound. I've tried it with 2D texture filtering off and it makes no difference.
#4
This game has always been problematic. With Clamp on extra/preserve fixes the characters being seen. Not sure how the latest build will handle speed wise.
#5
Has anybody found a fix for this? this game is the main reason i got pcsx2.
#6
(12-30-2011, 11:15 AM)Savre Wrote: This game has always been problematic. With Clamp on extra/preserve fixes the characters being seen. Not sure how the latest build will handle speed wise.

HI,
I`m getting the problem of character can not being seen.
all character are invisible ...
please kindly help to solve it.

how to "Clamp on extra/preserve"???




Users browsing this thread: 1 Guest(s)