Thread Rating:
  • 1 Vote(s) - 5 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low FPS + Graphical glitching in hardware mode [Please help]
#1
Hey guys, I've been mucking around and searching for help on the internet to try and fix issues that I've been having with the PCSX2 v9.7 emulator, with no luck so far I've decided to post a thread in hope that I can find some answers.

First my system specs :

CPU = Intel i52500 (Sandy Bridge) @ 3.4Ghz
Graphics = AMD HD6970 2GB
RAM = 4GB @ 1600Mhz
Audio = X-fi Titanium
O/S = Windows 7 (64 bit)

Note all drivers and updates are current with system.

The issue that I'm having is low FPS in software mode (f9) and some audio slowdown too.. I have tried to play in hardware mode but I am only met with below issue graphical problems... (only software allows me to actually see what's going on in-game)

Now as far as I'm aware my system should be more then capable of handling the emulator... I have read that 64bit isn't supported but I have seen people running the emulator successfuly on it.

Below SS's are attempting to run Gran Turismo 4... though all games that I have tried have suffered the same fate.

Help needed, would be much appreciated

Cheers!


[Image: 74154421.png]
[Image: 16131835.png]
[Image: 83625346.png]
Reply

Sponsored links

#2
For the garabage in hardware mode pause the game then in screen settings set the contrast/brightness to 0 and you shouldn't have the garbage problem anymore.

Software mode uses only the CPU to render graphics so it's much much slower, other than using frameskip (shift+F4) there's not much you can do about it and with frameskip it's much choppier gameplay.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Hi Shadow Lady,

Thanks for the quick reply, I am trying to pause the game to select the 'screen settings' option though I'm unable to move down to select that option, which is strange since my controls will work anywhere else in the game... I'm also using an Xbox360 controller for windows
Reply
#4
You need to use the d-pad buttons to move at the pause screen, make sure they're configured.

Alternatively you could change the picture settings from the main menu when you start the game "options > picture quality" and set everything to 0.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#5
(10-16-2011, 06:25 AM)Shadow Lady Wrote: For the garabage in hardware mode pause the game then in screen settings set the contrast/brightness to 0 and you shouldn't have the garbage problem anymore.

Software mode uses only the CPU to render graphics so it's much much slower, other than using frameskip (shift+F4) there's not much you can do about it and with frameskip it's much choppier gameplay.

(10-16-2011, 06:45 AM)Shadow Lady Wrote: You need to use the d-pad buttons to move at the pause screen, make sure they're configured.

Alternatively you could change the picture settings from the main menu when you start the game "options > picture quality" and set everything to 0.


Oh great ! that seems to be working thanks for that Smile

May I ask why that occurs?

Also the game now seems to be running too fast! is there any way to slow down the FPS to match intended FPS of the game? And if possible how would I adjust the resolution to make things look alot clearer ?

Thanks again Smile
Reply
#6
Try pressing the F4 and Tab keys and see if the speed stays at the intended 50 or 60FPS on your game.
You can try raising the scaling resolution in GSdx.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#7
(10-16-2011, 07:01 AM)Shadow Lady Wrote: Try pressing the F4 and Tab keys and see if the speed stays at the intended 50 or 60FPS on your game.
You can try raising the scaling resolution in GSdx.



hmm nope capping the framerate doesn't seem to help... it speeds up then slows down then goes normal etc constantly up and down hmm
Reply
#8
Hmm the game is still running slowly and the audio very choppy..... should I make a new thread for this? anyway, here are my current settings:

[Image: 30728702.png]
[Image: 42939997.png]
Reply
#9
Uh... you should restore the NTSC/PAL framerate to their defaults 59.94 and 50.


What speeds do you get now?

For better speed you can try enabling the "allow 8-bit textures" option in GSdx as well as enabling the new MTVU speedhack in the latest SVN builds:
http://forums.pcsx2.net/Thread-SVN-daily...-by-Orphis
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#10
It's running alot better but still not perfect.. very choppy from time to time and audio cuts in and out during a race

Im getting Fps of around 70-99 EE 78% GS 29% UI 0-1 %

Could it have something to do with D3d Internal res or scaling?
Reply




Users browsing this thread: 1 Guest(s)