Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low FPS in DBZ BT3 - Need help
#1
Hey guys, this is my first thread so hopefully it goes well.

I recently got PCSX2 and I used an actual PS2 copy of Dragonball Z Budokai Tenkaichi 3 and I managed to make an ISO file out of it for use. The game is running smoothly in 60 fps in the main menu but once I go into battle, my game drops to 30 fps and makes it very hard to play. I was wondering if you guys can help me out as I've been trying many different setting configs and read similar topics with the same problem but I had no hope. My PCSX2 version is 1.2.1

My PC Specs are:

Windows 7 Home Premium

Processor: Intel ® Core ™ i5-2450M CPU @ 2.50 GHz 2.50 GHz

RAM: 6 GB

System type: 64 bit

Video Card : Intel ® HD Graphics Family

Video Ram: 1.7 GB

3D: Yes

Sound Card: Intel ® Display Audio



So, can you guys help me out? I'll be trying out anything you guys recommend me to do and try each one until it solves the problem. Thanks
Reply

Sponsored links

#2
your CPu sin't too bad, but your GPu is kinda weak.
Make sure you use native resolution, set your windows power plan to performance mode, enable recommended speedahcks + EE Cycle rate to 1 (for a start...)

And then pray... Your GPu is probably going to bottleneck you, so don't expect miracle.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
The processor might be capable of doing 40+ on single player battles but, the GPU will lag it behind.
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#4
No luck guys. FPS is still the same. I guess my PC's GPU power just isnt good enough. But I'll keep trying; won't give up that easily.
Reply
#5
The budikai 2 and 3 are pretty intense. Least for my 8350 it was. Games use gpu hand in hand with those 2. I would say your system is pretty weak for them.
MOBO - ASUS Maximus VII Hero
CPU - Intel i7 4790k 4.4GHZ
RAM - 16 Gigs DDR3 2133mhz
HDD - 3 500 Gig SSD 1 3 TB 7200 RPM
GPU - EVGA Nvidia GTX 1070 SC
OS- Windows 10.
Reply
#6
Try to use skipdraw (GSDX -> HW hacks) with values between 1 and 10. It can remove effects and therefore reduce the load on your gpu.
Reply
#7
I tried all the values between 1 and 10 and still no change. Does it matter which GSDX I have? The ones I currently have are these: http://prntscr.com/7tvq79
Reply
#8
maybe try the latest development version from here: http://pcsx2.net/download/development/git.html
We're supposed to be working as a team, if we aren't helping and suggesting things to each other, we aren't working as a team.
- Refraction

[Image: 84t1dRu.png]
Reply
#9
You first go to emulation settings then go to GS. Use constant frameskipping. Set frames to draw 1 and frames to skip 2. This will increase fps but skip 1 frame constantly which would make you hard to play. I you are unable to play at that speed try frame to draw 2 and frames to skip 2. This meets the actual speed of original PS2 but may cause flickering. Hope it helped.
Reply
#10
(01-03-2016, 01:27 AM)PCSX2PS2 Wrote: This meets the actual speed of original PS2 but may cause flickering.

What is that supposed to mean?
Why is 2/2 frameskip the same as native ps2?
Reply




Users browsing this thread: 1 Guest(s)