Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low FPS (under 15) Ubuntu 12.10
#1
Hey guys,

I have searched and search but haven't found a thread that can help me specifically.

First of all specs:
Ubuntu 12.10 amd64
Intel i5-2410M
Nvidia GT540M
8Gb

Anything else?

I can't seem to configure PCSX2 appropriately to give me decent FPS. I usually get ~50FPS when the game is starting up, but as soon as it hits the menu it shoots down to below 15. I have managed to get it up to 25 at that point by changing some speed hacks settings but nothing playable yet. I've been testing mostly with Ratchet and Clank.

I'm also having to use Bumblebee to switch between integrated graphics and Nvidia so I'm launching PCSX2 using "Optirun". Are there any issues with this?

Any help would be greatly appreciated. If you require any more information please let me know.
Reply

Sponsored links

#2
Ratchet and Clank has known issues with running slow and buggy and requiring the most strongest of CPUs. And that's assuming HW mode on Windows! Plus Linux is only working in SW mode reliably which causes 100% of the demand on the CPU, so for now you can try perhaps to use ZZogl "No target resolves" hack. Sometimes that helps with speed.

Also make sure laptop power settings is set to high performance to prevent throttling. Watch out for heat if you do that. Plus use Nvidia proprietary drivers with PCSX2.
Reply
#3
(12-08-2012, 01:28 AM)DaTankAC Wrote: Ratchet and Clank has known issues with running slow and buggy and requiring the most strongest of CPUs. And that's assuming HW mode on Windows! Plus Linux is only working in SW mode reliably which causes 100% of the demand on the CPU, so for now you can try perhaps to use ZZogl "No target resolves" hack. Sometimes that helps with speed.
Hmmm, that's disappointing to hear. I might compare it with windows some day but I was hoping to not have to do that. I tried that hack but haven't been able to get the FPS up above 30.

(12-08-2012, 01:28 AM)DaTankAC Wrote: Also make sure laptop power settings is set to high performance to prevent throttling. Watch out for heat if you do that. Plus use Nvidia proprietary drivers with PCSX2.
I'm not too sure how to change the power settings? Yup I'm on the latest 310.14.

Thanks for your input.
Reply
#4
It's been awhile since I used Unity but there is a power management section in the settings.
Reply
#5
Also to add you could try a mild frame skip. For me I always have bad luck with that choice as it makes my games freeze, but who knows?...maybe it could work for you.
Reply
#6
(12-08-2012, 06:23 AM)DaTankAC Wrote: It's been awhile since I used Unity but there is a power management section in the settings.
There is but it's just to do with what to do when the battery is plugged or unplugged.

(12-08-2012, 06:28 AM)DaTankAC Wrote: Also to add you could try a mild frame skip. For me I always have bad luck with that choice as it makes my games freeze, but who knows?...maybe it could work for you.
I'll give it a go later on. Thanks.
Reply




Users browsing this thread: 1 Guest(s)