Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low fps
#1
Hi, I have a strange problem with pcsx2,
I had the GPU 8800gt and a gt610 and it works fine,
but with my HD 4870 if I play Shadow hearts, for example,
the FPS go down to 6-15fps if I use
Gsdx in hardware mode, or opengl in hardware mode,
in software mode the game go at 60fps.

I've tested all the options of pcsx2, changed plugins,
emulation settings but nothing,
Reply

Sponsored links

#2
whats your cpu? this thread is also in the wrong section
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
moving
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#4
Have you updated your drivers? What are your settings for pcsx2?
Reply
#5
Sorry by the wrong section.
My cpu is a Core 2 duo 6750, 2.66ghz x2
4GB RAM DDR2

I have the last drivers of the 4870, tested various pcsx2 versions
and same problem, in windows xp 32 bits, and windows 7 64bits

So the problem is this ATI 4870 in pcsx2, the vga works
fine with games, other emulators, etc but no with pcsx2.
Reply
#6
(12-10-2013, 05:24 PM)gadesx Wrote: Sorry by the wrong section.
My cpu is a Core 2 duo 6750, 2.66ghz x2
4GB RAM DDR2

I have the last drivers of the 4870, tested various pcsx2 versions
and same problem, in windows xp 32 bits, and windows 7 64bits

So the problem is this ATI 4870 in pcsx2, the vga works
fine with games, other emulators, etc but no with pcsx2.

Make sure pcsx2 is actually using your graphics card instead of your chipset.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#7
(12-10-2013, 05:33 PM)Nobbs66 Wrote: Make sure pcsx2 is actually using your graphics card instead of your chipset.

tested with the ati selected, and default but the same
[Image: l15.png]
Reply
#8
In the Hardware-Mode section everything is ticked. I am not sure about the directX9 version but you should probably untick everything except for texture filtering which should be filled as it is.

Especially Enable HW Hacks should be turned off since it can harm your game...
Reply
#9
With all ticked 16fps. without all 18fps in hardware mode

with open gl says

3.x GL context successfully created
Supported Opengl version: 3.3.11672 Core Profile/Debug Context on GPU: ATI Radeon HD 4800 Series. Vendor: ATI Technologies Inc.
Buggy driver detected, GL_ARB_separate_shader_objects will be disabled
INFO: GL_ARB_separate_shader_objects is not supported
INFO: GL_ARB_gpu_shader5 is not supported
INFO: GL_ARB_shader_image_load_store is not supported
Reply
#10
Bad gpu driver for sure. This explains why your system works much better in SW mode. That's the same message you get on Linux version if the driver is acting up (since the OpenGL plugin is the same as Linux and Windows). Go to AMD's website and download the amddriverdownload.exe file. This will give you the optimal driver for your system. Since your card is now considered "legacy" you won't be able to get the best outcome needed. But this would probably be better than using the Windows default driver it chooses.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply




Users browsing this thread: 1 Guest(s)