Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Low fps on good computer
#1
Sad 
I want to play Midnight Club 3, when I stop the fps goes to 60 similarly with the menus, if I go over 50 mph I get around 25 - 40 fps and it makes the sound of the game go slow motion, can you please suggest anything that could improve the games performance.

i5 2500k
XFX HD 5770
4GB RAM
Reply

Sponsored links

#2
Pcsx2 settings?

For starters, enable the MTVU speedhack and running it on D3D11 (Hardware) or (Software).
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#3
(08-22-2012, 02:36 PM)PyroBunta Wrote: Pcsx2 settings?

For starters, enable the MTVU speedhack and running it on D3D11 (Hardware) or (Software).

Config < Emulation settings < Speed hacks

looks like a GPU bottleneck so do this :

1- tick the box native :

Config < Video < Plugin settings

didn't work :

2- enable all recommended Speedhacks and experiment VU cycling and EE cycle rate with each level Smile

Config < Emulation settings < Speed hacks


3-set the power plan to "High performance"

4-disable any AntiVirus and any Program consuming the CPU

and tell us the percentage of EE and GS while having slowdowns
Reply
#4
(08-22-2012, 02:36 PM)PyroBunta Wrote: Pcsx2 settings?

For starters, enable the MTVU speedhack and running it on D3D11 (Hardware) or (Software).

I put enable speedhacks and put both the bars at 3 and now it's slightly better
Reply
#5
Midnight club is monsterous on video memory usage, keeping your internal resolution down or using "Native" resolution will probably render the need for using the speedhack sliders useless, but at the cost of prettyness Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
With Native resolution:

Speedhacks Disabled: Driving Fast. EE 98% GS 80-90%

Speedhacks Enabled EE 2, VU 0 : Driving Fast. EE 50-65% GS 80-90%
http://gyazo.com/0ad594a29001923fcce9618d78824c09

Speedhacks Enabled EE 2, VU 1 : Driving Fast. EE 50-65% GS 80-90%
http://gyazo.com/98b2ce68671d4b207d78dfff139d2b1b

Speedhacks Enabled EE 2, VU 2 : Driving Fast. EE 45-60% GS 80-90%
http://gyazo.com/435ac113e08990ac3a78e94af96372d2

Speedhacks Enabled EE 2, VU 3 : Driving Fast. EE 40-50% GS 75-85%
http://gyazo.com/2306d74d31c496c72b7b0d82ef179ce3

Speedhacks Enabled EE 3, VU 3 : Driving Fast. EE 35-45% GS 70-80% (says 60fps, feels like 10)
http://gyazo.com/cd07e853c9002996be8dcba13ae81597
Reply
#7
Yeah, your GPU is bottlenecking the emulation. Turn off 8-bit textures and/or texture filtering if you don't mind the game looking worse.
CPU: Intel Core i5-3470 Quad Core @ 3.6GHz
RAM: 8GB
GPU: Nvidia GeForce GTX 660 Ti
OS: Windows 7 Ultimate x64
Reply
#8
(08-22-2012, 04:06 PM)PyroBunta Wrote: Yeah, your GPU is bottlenecking the emulation. Turn off 8-bit textures and/or texture filtering if you don't mind the game looking worse.

I turned them off and I saw no performance rise :/
Reply
#9
Try setting the Skipdraw option in GSDX under hardware hacks to 1, if that isnt better, try 2 and so on up to about 20 to see if it makes a difference. I suspect it's some sort of post processing killing the performance.

As for your says 60 feels like 10fps, that's the nature of speedhacks, they cause false FPS, even more so when the hacks arent doing anything. If they arent doing anything (which it looks like) its best to keep the 2 sliders at zero, the other hacks don't effect the framerate in the same way.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#10
(08-22-2012, 04:33 PM)refraction Wrote: Try setting the Skipdraw option in GSDX under hardware hacks to 1, if that isnt better, try 2 and so on up to about 20 to see if it makes a difference. I suspect it's some sort of post processing killing the performance.

As for your says 60 feels like 10fps, that's the nature of speedhacks, they cause false FPS, even more so when the hacks arent doing anything. If they arent doing anything (which it looks like) its best to keep the 2 sliders at zero, the other hacks don't effect the framerate in the same way.

went from 1 to 20 frame skipping and sadly I saw no difference :/
Reply




Users browsing this thread: 1 Guest(s)