Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS 3 Snake Eater
#1
Sad 
Hi all. Need some help. While trying to play in MGS 3 i have faced an error which is called "wmhack". It appears just after Snake enters second location (swamps) from the start. I have tried different plugins, different pcsx2 builds - no effect. What could it be? Conf: E8500, 4 GB RAM, GF 9800 GT 512. Sad

Sponsored links

#2
(12-13-2008, 12:37 PM)HedEE Wrote: Hi all. Need some help. While trying to play in MGS 3 i have faced an error which is called "wmhack". It appears just after Snake enters second location (swamps) from the start. I have tried different plugins, different pcsx2 builds - no effect. What could it be? Conf: E8500, 4 GB RAM, GF 9800 GT 512. Sad

I think you mean "VMhack" i think happens when the game floods the memory, and is unable to load, you'd problably need a patch, tho im not entirely sure what im talking about Tongue
#3
(12-13-2008, 01:10 PM)azure6610 Wrote:
(12-13-2008, 12:37 PM)HedEE Wrote: Hi all. Need some help. While trying to play in MGS 3 i have faced an error which is called "wmhack". It appears just after Snake enters second location (swamps) from the start. I have tried different plugins, different pcsx2 builds - no effect. What could it be? Conf: E8500, 4 GB RAM, GF 9800 GT 512. Sad

I think you mean "VMhack" i think happens when the game floods the memory, and is unable to load, you'd problably need a patch, tho im not entirely sure what im talking about Tongue

Uh no it has nothing to do with that,and a patch can not fix it...if you don't know what you're talking about don't reply please Tongue

If i recall correctly the game has various crashing bugs like that which got fixed then broken again in various SVN revisions...you might want to give the playground version a try see if it's fixed there
[Image: newsig.jpg]
#4
(12-13-2008, 01:12 PM)Bositman Wrote:
(12-13-2008, 01:10 PM)azure6610 Wrote:
(12-13-2008, 12:37 PM)HedEE Wrote: Hi all. Need some help. While trying to play in MGS 3 i have faced an error which is called "wmhack". It appears just after Snake enters second location (swamps) from the start. I have tried different plugins, different pcsx2 builds - no effect. What could it be? Conf: E8500, 4 GB RAM, GF 9800 GT 512. Sad

I think you mean "VMhack" i think happens when the game floods the memory, and is unable to load, you'd problably need a patch, tho im not entirely sure what im talking about Tongue

Uh no it has nothing to do with that,and a patch can not fix it...if you don't know what you're talking about don't reply please Tongue

If i recall correctly the game has various crashing bugs like that which got fixed then broken again in various SVN revisions...you might want to give the playground version a try see if it's fixed there

I tried the playground version - the same thing
#5
So what is a vmhack? when i use the VMversion on a game hat crashes and reads "vmhack" it just closes pcsx2. where if i us a non vm version, it tries to read the same parts of the iso over and over, without any loading.
#6
(12-13-2008, 01:16 PM)azure6610 Wrote: So what is a vmhack? when i use the VMversion on a game hat crashes and reads "vmhack" it just closes pcsx2. where if i us a non vm version, it tries to read the same parts of the iso over and over, without any loading.

Since it gets in an endless loop. Just like back in good old basic where you`d have infinite loops like:

10 print "Never ending loop"
20 goto 10

Course whats happening in the case of Snake Eater is a little more complex.
Old habits die hard - System Shock
#7
MGS3 is still far from playable, not much you can do with it.
#8
(12-13-2008, 01:16 PM)azure6610 Wrote: So what is a vmhack? when i use the VMversion on a game hat crashes and reads "vmhack" it just closes pcsx2. where if i us a non vm version, it tries to read the same parts of the iso over and over, without any loading.

vmhack happens when pcsx2 tries to read an invalid memory address.

it means that something went-wrong with pcsx2, and its a hack to try and fix it. but it rarely works.

it sometimes works though, and lets you move-on in some games.

all it takes is a small-incorrect computation, and you can get a completely broken game in emulation. so stuff is hard to find/fix.
#9
Go to Advanced settings and change EERec round mode to negative. Game is 100% playable. I think I already finished it on pcsx2 long time ago. Current PP versions got a problem with movie playback (movies will work for 2-3 seconds then hang for 20-30 seconds then start working again) so make sure you skip the movies.
#10
(12-13-2008, 04:59 PM)prafull Wrote: Go to Advanced settings and change EERec round mode to negative. Game is 100% playable. I think I already finished it on pcsx2 long time ago. Current PP versions got a problem with movie playback (movies will work for 2-3 seconds then hang for 20-30 seconds then start working again) so make sure you skip the movies.

thanks, looks like it's working Smile. but movies, any ideas? at first movie (until snake drop off) all works normally (except sound), but after drop off - realy movie played for 2-3 sec and freezed for 20-30 sec.




Users browsing this thread: 1 Guest(s)