Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS 3 Speed Behavior
#1
Hi

I just tried recently MGS3 again with a new beta (2756) and noticed something weird. During the opening there are several parts when the game slows down. Now, this wouldn't be surprising since it's incredibly demanding. But, neither the EE-Core nor the GPU score in the title showed a usage of around 99%. So, what exactly is the bottleneck in this game?

Information:

4.0 Ghz Clockspeed I5
EE Core Usage and Graphic were both at around 55-60%
No speedhacks activated
It slowed down to around 35-42 fps during these scenes.

Also I brought my clockspeed down to 3.6 Ghz but noticed the exact same behavior. (EECore was around 80% that time though)

(I don't ask for support, but I'm interested in the cause)
Reply

Sponsored links

#2
If neither EE or GS went around 90% it means you're probably limited by your graphics card, try ticking the "native" checkbox in GSdx.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
Have you tired running it on PCSX2 0.96 rev 1888 to see whether or not it's the beta slowing it down?
Reply
#4
Doesn't the GS Thread suggest the performance load on the graphics card?

Anyway, tested and same result
Reply
#5
(03-21-2010, 08:31 PM)C2B Wrote: Doesn't the GS Thread suggest the performance load on the graphics card?

Anyway, tested and same result

That was true in the old GUI where GSdx would show both the CPU and GPU load of the plugin, in the new GUI it doesn't seem to do that (I can easily set a 4096x4096 custom resolution and get 10% GS and EE in the new GUI which would seem to show only the CPU usage).

In any case, use the latest public beta and show us your settings if you want us to help with your speed problem, it would also help if you tell us your graphics card.

Oh and while you're at it check if GSdx shows a ~90% CPU usage there Tongue
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply




Users browsing this thread: 1 Guest(s)