Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS2 Aiming Issue
#1
Hey, new to PCSX2 and emu's in general. I'm playing MGS2: Substance on PCSX2, and everything runs perfectly so far (except for this bug[?]) I'm about to describe. Couldn't find anything about aiming specifically for MGS2, just suggestions for general performance increase.

When in first person view mode and aiming a gun, if you get too close to a wall and face it while aiming, Snake will hold the gun so it points up in the air (since you can't hold your arm through the wall). He's been doing this just about every time I try to aim in 'narrow' hallways, like he thinks there's a wall in front of him. It's as if the game thinks the walls are in a different spot than they actually are (ONLY while aiming, though).

Screenshot of Aiming bug

Does this sound like an issue with the emulator or the ISO I'm using? Whatever the cause, any suggestions about fixing it? Can't use the disc, it's so scratched it locks up during the Konami intro screen.

Edit: I'm using PCSX2 0.9.8. System specs:
Intel I5-2500K
GeForce GTX 550 Ti
8 GB DDR3
Win7 x64 SP1
Reply

Sponsored links

#2
It does that on my PS2... It's because Hideo(The crazy man) dosen't think human arms can go through solid walls. Biggrin

Edit: Pardon me I should read more carefully before making comments Tongue. That is odd actually, I don't get that on the emulator. What are your Pcsx2 settings? You can post screenshots using the camera icon.
CPU: i9 20Ghz 40-core
GPU: GTX 129000 in Octo-SLI
RAM: 64GB DDREKT69
Monitor: 800x600 15" CRT
Reply
#3
Yeah but the issue is that it does it when NOT facing walls. It makes combat rather difficult.
Reply
#4
Well given the "Type" of problem it is, could you tell us what your Round and Clamp modes are?
CPU: i9 20Ghz 40-core
GPU: GTX 129000 in Octo-SLI
RAM: 64GB DDREKT69
Monitor: 800x600 15" CRT
Reply
#5
Not sure which settings are needed here, and you lost me when referring to the "camera" button, so I just used Windows' snip-it tool. If this SS is too small/undefined I can post larger ones of each screen separately.

Settings Screenshot
Reply
#6
Try tweaking the rounding/clamping modes for both the VUs and the Interpreter and see if you get any different results.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#7
Thanks for the suggestion. Gotta head out for a bit, but I'll play with those when I get back and post the results.
Reply
#8
Right on. I couldn't tell you if the clamping/rounding modes, but make sure that you after you change the clamping/rounding modes, load from a memory card savepoint to make sure it has taken effect.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!



Keep safe with MyWOT.

I have everything...
Reply
#9
This is an example from my Pcsx2. Think you'll notice the button now. Tongue


Attached Files Thumbnail(s)
   
CPU: i9 20Ghz 40-core
GPU: GTX 129000 in Octo-SLI
RAM: 64GB DDREKT69
Monitor: 800x600 15" CRT
Reply
#10
No go on the Round/Clamp settings. I tried them all under both EE/IOP and VUs tabs. I also tried running with Interpreter/Recompiler on both tabs as well (at this point, I'm just fiddling with random settings of which I don't know the repercussions). Perhaps I'll just have to practice being sneakier, and run when I accidentally sound the alarm. Sad

Edit: And thanks Fezzer for pointing out the camera button! I had no idea it was there.
Reply




Users browsing this thread: 1 Guest(s)