Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS3 running super slow
#1
New to PCSX2 and having issues trying to run MGS3 at a playable speed running it from a PAL DVD and the FPS is around 10, fairly sure it's my settings so if possible could someone point me in the direction which shows the best settings/plugins that will help run most games at full/playable speeds.
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
1. Make iso of the game with imgburn.
2. What are you PC specs MGS3 is one of the more demanding games.
Reply
#4
Sorry I made the noob error of not posting my hardware.
OS: Windows 7 64bit
CPU: i5 3570K @ 4.3GHz
RAM: 8GB
GPU: GTX 770
Version 1.2.1 I am pretty much using default settings for now only change one sound setting to Xaudio as I got no audio at all before.

Games I will be running. MGS3, MGS2, Final fantasy 10,10-2 and 12. I will be running the games via DVD and they will all be in the PAL format as I'm in the UK (no NTSC discs here)

Not really sure what is causing the games to run slow as I pretty sure my hardware should perform a lot better than it currently is.
Reply
#5
it's better to make an iso of the game! cause its faster! ok your machine is enough to run anything at 3x! so this is curious for me to understand why you got less fps!

+ maybe a some thing trotting or power plan isn't set to performance or something wrong in your pcsx2 settings ! use defult settings and try again!
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#6
(07-24-2014, 09:02 PM)Brock lessner Wrote: it's better to make an iso of the game! cause its faster! ok your machine is enough to run anything at 3x! so this is curious for me to understand why you got less fps!

+ maybe a some thing trotting or power plan isn't set to performance or something wrong in your pcsx2 settings ! use defult settings and try again!

Power plan is set to performance, it could be down to settings as Dolphin emulator runs perfectly with enhancements up high and that is also CPU intensive. Will also rip my discs if that would help.
Reply
#7
don't compare dolphin emulator to pcsx2! pcsx2 is much harder to emulate ! anyway ! rip the iso and try with default setting and then tell me what the results are!
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#8
(07-24-2014, 09:31 PM)Brock lessner Wrote: don't compare dolphin emulator to pcsx2! pcsx2 is much harder to emulate ! anyway ! rip the iso and try with default setting and then tell me what the results are!

With default settings(just controls changed) and running off a ISO the game ran alot better full speed but did stutter a couple times, sound glitched up at points(alert sound caused it) and from memory it looked a little worse than the PS2 did guess I need to config the "enhancements" now.
Reply
#9
great news !
Pentium Dual-core G2010 2.8Ghz
RAM=4GB
nvidia GT 610
pcsx2 version-1.3.1  


Still surfing with Browser?, Try the pcsx2 forum App !
Reply
#10
(07-24-2014, 10:02 PM)Brock lessner Wrote: great news !

TY for the help, not sure if it was a setting or my DVD drive which caused the massive slowdown I had before.
Reply




Users browsing this thread: 1 Guest(s)