Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
MGS3S runs at 67FPS fine but then..
#1
Firstly I just want to thank the team for such an amazing emulator, you guys are great!

This is not a moan about a performance issue with PCSX2 but rather my curious mind trying to understand what is going on.

MGS3S the NTSC version yesterday was running at a smooth 67FPS (the 60fps hack was enabled). No hiccups whatsoever, except for the occasional black textures spots which cause no real issue. I was playing at 3X native and impressed at how smooth it was running I even bumped it up to 4X with no issue. It wasn't slowing down at any point, the cut scenes ran fine too! So impressed.

Today, I popped in The Godfather and it had a few issues, change some of the settings. Naturally, I went back to MGS3 to continue playing, I can barely keep 60FPS? Really laggy, extreme slow downs and various issues. I reconfigured the HW hacks back for MGS3S, which is a skipdraw setting of 67 that's it. Still really slow, I disable the 60FPS hack, still slow. I reset all settings, and give it another go. A mild improvement.

I'm not bummed or anything, just extremely intrigued as to how it can play ever so smooth one night, and then terribly the next. It was running at a firm 67fps, with the 60fps hack on with no issues. Has this got to do with my CPU parking setting? Forgive me if I am making no sense lol...

My system is as follows.

Pentium G4560
RX 480 OC
8GB DDR4
Reply

Sponsored links

#2
(04-01-2017, 01:20 PM)Bretmaster5 Wrote: Firstly I just want to thank the team for such an amazing emulator, you guys are great!

This is not a moan about a performance issue with PCSX2 but rather my curious mind trying to understand what is going on.

MGS3S the NTSC version yesterday was running at a smooth 67FPS (the 60fps hack was enabled). No hiccups whatsoever, except for the occasional black textures spots which cause no real issue. I was playing at 3X native and impressed at how smooth it was running I even bumped it up to 4X with no issue. It wasn't slowing down at any point, the cut scenes ran fine too! So impressed.

Today, I popped in The Godfather and it had a few issues, change some of the settings. Naturally, I went back to MGS3 to continue playing, I can barely keep 60FPS? Really laggy, extreme slow downs and various issues. I reconfigured the HW hacks back for MGS3S, which is a skipdraw setting of 67 that's it. Still really slow, I disable the 60FPS hack, still slow. I reset all settings, and give it another go. A mild improvement.

I'm not bummed or anything, just extremely intrigued as to how it can play ever so smooth one night, and then terribly the next. It was running at a firm 67fps, with the 60fps hack on with no issues. Has this got to do with my CPU parking setting? Forgive me if I am making no sense lol...

My system is as follows.

Pentium G4560
RX 480 OC
8GB DDR4

67 fps with skipdraw set to 67?
#StopRNG
Reply
#3
May seem obvious but make 200% sure PCSX2 is using your RX 480. E.g Hardware mode
Lenovo Y50-70 Gaming Laptop
Intel Core i7-4720HQ @ 2.6Ghz - 3.6Ghz Quad Core
Nvidia GTX 960M 4GB
8GB DDR3 Ram
15.6'' Full HD 1920 x 1080 IPS
Windows 10 64 Bit
---
Intel Core i5 4670 @ 3.4Ghz
Gigabyte H81M
Gigabyte Radeon R9 280X 3GB
8GB DDR 3 Ram
1TB WD Black
Windows 10 64 Bit
Phillips 23.6" 1920x1080 IPS
Reply
#4
everyone is gonna yell at me, but turn down the EE slider to -1 and it might improve. I noticed major lag on my old PC till I did that, ESPECIALLY on codecs
Reply




Users browsing this thread: 1 Guest(s)