Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Major FPS drop on Grandia III
#1
Im really in need of some help here, would be great to have some feedback on this issue..

Basicly im having extremely bad fps drops on Grandia 3 specificly - During the video's when the characters are talking to one another. the Voices of the characters are completely out of synch with the video. The FPS on the video's is fine one minute. Then as soon as im in a built up area, the fps will drasticly drop down to 35% and the stuttering is off the scale.

I have the very latest version PCSX2 0.9.7 (r3878) I also have every plugin out there avalible. Currently running under:

Video Plugin: gsdx-sse4-r3878, Direct3D11 (hardware), Interlacing: None. D3D Upscaling X1, Internal Res: 1024x1024.
Sound: SPU2ghz Output mode: XAudio2, Interpolation: Cubic. Buffer Size: 1024.
CDVD: cdvdGigaherz: (Currently loading the Image from Disk)

Im Currently Running no speedhack -
(Have also Tried Speedhacks ie, Used every setting i possibly can)
Ive also used frame skipping and to no avail it doesnt seem to even touch the Video's at all.
VU's: VU0 & VU1 are currently set to Micro. Round mode: Chop/Zero. Clamping Mode: Normal.
EE/IOP: EmotionEngine & IOP are set to Recompiler.
EE/FPU: Chop Zero Chop/Zero

My System specs are:
Intel Core i7 920 @ 2.67GHz.
Windows 7 Home Premium 64-bit SP1.
6.0GB Triple-Channel DDR3 @ 668MHz.
2 ATI Radeon HD 5700 Series (Crossfired).
1TB Western Digital Hdd.


This is the first game ive ever had real trouble with, as ive emulated everything else Perfectly in the past. any advice would be welcome, Thank you.




Reply

Sponsored links

#2
The realtime rendered cutscenes in Grandia 3 are pretty demanding. Disable CF and see if that helps. Might just need more CPU speed though.
CPU: Intel i7 2600k @ 4GHz
GPU: ASUS GTX580 @ stock
RAM: 8GB (2x4) DDR3 PC3-10600
MB: ASRock P67 Pro3
OS: Win7 Pro 64bit
Reply
#3
Turning off CF didnt seem to do a thing.. and from my understanding by default PCSX2 has always used 1 card even if Crossfired.. atleast that is what i have read.

Its very hard to know what it is for sure that can cause this stuttering on the video's. im beggining to think its related to the sound. The sound works perfectly when not in a video, but as a video starts up.. the speech is miles ahead of the video. even though its told to run in complete Synch with the video. Thing is ive tried just about every method i can think of to get it going and have Failed on every step so far.. :\
Reply
#4
Use SPU2-X and enable timestretching.
Also make sure you didn't touch the NTSC or PAL framerate setting on the GS configuration page.
Reply
#5
(04-14-2011, 10:02 PM)rama Wrote: Use SPU2-X and enable timestretching.
Also make sure you didn't touch the NTSC or PAL framerate setting on the GS configuration page.


I Tried this and SPU2-X on this game is a definite no.. it sounds fine one minute. next you get a huge beep thats never ending comming through your speakers.. and no matter how many times i try switching to different versions of SPU2-X the outcome is the same..
Reply
#6
SPU2-X works fine on my version of Grandia III, I cant really say if it works ok with cutscenes though since I skip them.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#7
(04-14-2011, 11:35 PM)GamerGeek Wrote: SPU2-X works fine on my version of Grandia III, I cant really say if it works ok with cutscenes though since I skip them.

GamerGeek, can you Confirm your version of SPU2-X ? only ive just found the solution to the sound with this plugin. Im not entirely sure if its just on my end or maybe it Affects everyone else as well.

I was messing arround with Different versions of SPU2-X and i found out that "spu2-x-r-3878" has a problem related to sound on this game.

(atleast on my side till you can confirm this)

"spu2-x-r3117" With Interpolation Linear. Simple/nice. & Module: XAudio2 Works Perfect, So somewhere along the line version up from 3117 messed up the audio on this game.

Also as for the Audio Synch on the video's, Yet again im still Struggeling with this issue, I used "Timestretch" and as soon as i did i noticed the obvious, That being that the ingame sounds such as the menu and ingame battle sounds or simply footsteps, Was affected. It cleared up the video's however. But did the reverse to the other sounds.

Ive found out that alot of people out there are having this issue with this game related to the audio not being in Synch with the video.. Im going to attempt to use PCSX2 0.9.5. As ive recently read a random post on another forum and someone mentioned he got it all working fine with an older version.


Reply
#8
Please keep using the latest PCSX2, GSdx and SPU2-X versions. Just disable reverb in SPU2-X.
That should get rid of the weird noises issue. (If it does not, please report back.)
Reply




Users browsing this thread: 1 Guest(s)