Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Major Noobage - Trouble with FIFA World Cup 2006
#1
Hello there,

I'm new to the PCSX2 emu. I love ePXSe but I figured its time to move on to a PS2 emu!

I followed the excellently clear guide on this site for setup, but I'm having trouble with FIFA 2006 World Cup? I've linked 2 screenshots to show what I mean:

http://img541.imageshack.us/i/fifafuckedup.png/
http://img641.imageshack.us/i/fifafuckedup2.png/

The menus and such are fine, but when I start playing the textures aren't working properly, and the framerate is dropping from 50fps to average of 25fps. Its a PAL game and I'm running PAL BIOS, which is why 50fps.

I'm running it on an Alienware M17x (I know laptops arent the best but the hardware should support PCSX2).

Intel i7 M620 @ 2.67HGz
ATI Radeon Mobility HD 5870
4.00GB RAM
Windows 7 64-bit

I'm sure this kind of thing comes up all the time from newbies, any help anyone can offer would be really appreciated Smile

Maybe I'm underestimating the hardware required to run this level of emulation? Hopefully its just a config issue!
Reply

Sponsored links

#2
Pcsx2 settings, plugins settings, pcsx2 version ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
You need to post more info as jesalvein asked so we can help better. For now I can give some tips since I've tried some of the fifa games before.

Try either raising the VU clamps to extra or higher or switching to the superVU recompiler, also try using a (Software) renderer on GSdx (can do while playing by pressing the F9 key). Either case should help with the textures problem but probably be too slow then.

For speed you can enable the "native" option in GSdx and also try speedhacks, specifically "VU cycle stealing" speedhack could help a lot.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
Hi people,

Thanks so much for your speedy replies, sorry if I didn't post enough information!

I followed Shadow Lady's advice and got the speed up to around 45fps, so damn near full speed. I hit F9 and the textures look exactly like they should do, but the speed does indeed drop back to about 25fps, even with the speedhacks.

I'm using the latest PCSX2 (0.9.7)
GSdx SSE41 Direct3D11 (Hardware), not using native resolution

Emotion Engine settings are currently:
Round mode: Chop/Zero
Clamping Mode: Normal
Flush to Zero: Checked
Denormals are Zero: Checked

VUs
MiroVU for VU0 and VU1
Round Mode: Chop/Zero
Clamping Mode: Extra + Preserve Sign
Flush to Zero: Checked
Denormals are Zero: Checked

Any other info needed please let me know, and thanks again!
Reply
#5
hmm... In the emulation settings, under the GS section, you dont have synchronize GS ticked do you?? Your usage figures along the top look very odd.

you could also try checking your power options in windows and making sure it is set to "maximum performance" when plugged in.

either you are running off a single core of the 2, or windows is limiting you.

Note: If you change the power settings, make sure your laptop is well cooled.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
No synchronise GS isn't ticked in the emulation settings. I changed up to high performance on my machine but it only raised the fps from about 26 to 30.

Is there any way to test if I'm only running on 1 core? Or else is there seomthing else in the setup that I need to change? AGin, any more info needed, please ask.
Reply
#7
(03-30-2011, 09:07 PM)OWLovethBL Wrote: Nope synchronize GS isnt ticked, and "high performance" serves only to raise the frame limit from about 25 to 30fps.

Any way to check if the emu is utilising the full potential of the machine? Any other suggestions?

Thanks.

open task manager and go to performance. If you don't see multiple graphs go to view, cpu history and set it to one graph per cpu and play pcsx2 and see if 2 cores are getting under load
Reply
#8
I looked at my CPU usage while running the game, and I have 4 graphs to looks at, and all are showing decent activity. CPU usage peaks at abour 35%, and yet the game is still only running at about 25-40fps.

Is there something in the config I've done wrong?

Thanks for your support everyone.
Reply




Users browsing this thread: 1 Guest(s)