Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Making my pc and FFX fit
#1
Hey everyone,

I have a pc with the following hardware/software:
3GHZ Duo core, 2gb of RAM, GeForce 9400GT + winXP.

I have recently downloaded the latest pcsx2 version, and I'm willing to play Final Fantasy X and get the best results, yet without getting "slow moments". By saying that, I mean that even though the graphics looks really good and that game runs generally well, when there's an explosion scene or something like that, the game starts to run much slower for a few moments (until that scene is over) -- E.g, when an enemy casts "Demi".

What can I change in my video card / general pcsx2 settings in order to avoid slowing down in those scenarios? Of course, I am willing to give up some graphic performances.


Thanks in advance.
Reply

Sponsored links

#2
Try reducing the internal resolution in GSdx or simply ticking the "Native" option, also make sure the "Allow 8-bit textures" option is disabled for this game.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#3
The Demi spell takes quite much GPU power. You need at least a 9600 GS if you do not want it slows down the game. Otherwise try what Shadow Lady said above.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#4
Thanks a bunch.

What resolution do you think will do best?
Reply
#5
1024x1024 or 2x native.
if it slows down too much: just use native.

oh yeah, if you would run win7, DX10 would help speeding some GPU demandig effects like demi up.

Main Rig: i7-3770k @4.5ghz | 16GB DDR3 | Nvidia GTX 980 TI | Win 10 X64
Laptop: MSI GT62VR | i7-6700HQ | 16GB DDR4 | Nvidia GTX 1060 | Win 10 X64

Reply




Users browsing this thread: 1 Guest(s)