Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mapping mouse button controls?
#1
Hello, all,

I just got PCSX2 so I can play my PS2 games on my laptop during long trips. I have everything set up except for one major problem: I want to use my USB mouse's LMB as the X button for most of the game I have, but when I map it that way it doesn't work. I know that the games are recognizing my keyboard mapping, because those keys work. It also works if I map the X button to a key on the keyboard. However, since I don't want to take a controller with me, I'd really like to map the camera control to the mouse axis and the attack (X) control to the LMB. Lilypad seems to recognize the selections without a problem, but they don't work in game. I've tried Direct Input, Raw Input, and Windows Messaging. I've made sure that "Direct Input," "X Input," and "Monitor when in background" are all checked. Any idea what I need to do so the emulator recognizes the mouse button? Right now I can't even start Kingdom Hearts -- the X button is the menu select...I've uploaded a picture of my control map, just in case it'll make a difference.

Thank you for any advice!


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Just a side info: camera movement in kingdom hearts is done by L2/R2 not by the R-stick. So don't expect that your current configuration will allow you to move the camera.

Have you tried disabling xinput? I don't think you need it. Unfortunately you croped the image. Is this pad1 or pad2?
Reply
#3
(04-25-2016, 05:08 PM)willkuer Wrote: Just a side info: camera movement in kingdom hearts is done by L2/R2 not by the R-stick. So don't expect that your current configuration will allow you to move the camera.

Have you tried disabling xinput? I don't think you need it. Unfortunately you croped the image. Is this pad1 or pad2?

Does it? I could have sworn the stick was the camera control and L2/R2 were command shortcuts. Although I haven't actually sat down and played any PS2 game in a while, so I could be remembering a different one. 

I've tried disabling both Xinput and Monitor in Background, but neither seemed to do anything. Also, this is PAD1 since that's the default.
Reply
#4
IIRC it is R-stick in KH2 but in KH1 it is still a 1D camera movement by L2/R2.

I guess you tried all combinations of buttons? Like press start?

Can you just map the x to a keyboard key to make sure that there is no other problem?
Reply
#5
(04-25-2016, 05:56 PM)willkuer Wrote: IIRC it is R-stick in KH2 but in KH1 it is still a 1D camera movement by L2/R2.

I guess you tried all combinations of buttons? Like press start?

Can you just map the x to a keyboard key to make sure that there is no other problem?

Oooh, I must be remembering KH2, then. That is the one I've played more recently. Anyway, if I can get the mouse to register I can change things around.

Yes, I've tried pressing start and select and circle and triangle and all that. The left stick->WASD mapping allows me to scroll up and down in the menu as I would expect. And as I said in the original post, "It also works if I map the X button to a key on the keyboard. However, since I don't want to take a controller with me, I'd really like to map the camera control to the mouse axis and the attack (X) control to the LMB." I do a lot of gaming on PC and I don't think that there's a setup that's more intuitive (or easier on the hands and wrists) than using WASD for movement, mouse for camera and attack, Space for jump, E for interaction, and the other buttons near WASD (like Q, Shift, and Ctrl) for additional, less common commands.
Reply
#6
Can you please test your mouse in the test device panel on the first tabpage?
To leave the panel press Alt+F4.

When you click the LMB do you see a 1 next to it?

Edit:
I just tried it quickly and hat the same issue as you. I never used the mouse but a lot of people did.... So I think it should work. Maybe you can check an/some older version/s (maybe 1.2.1, 1.0)? We had some changes regarding the window creation and possibly there is some focus problem. I don't know. Or one has to tick another tickbox in lilypad settings. Unfortunately I need to leave now and can not help you further for the moment. Next time I am on pc will be tomorrow I guess.
Reply
#7
(04-25-2016, 06:40 PM)willkuer Wrote: Can you please test your mouse in the test device panel on the first tabpage?
To leave the panel press Alt+F4.

When you click the LMB do you see a 1 next to it?

Edit:
I just tried it quickly and hat the same issue as you. I never used the mouse but a lot of people did.... So I think it should work. Maybe you can check an/some older version/s (maybe 1.2.1, 1.0)? We had some changes regarding the window creation and possibly there is some focus problem. I don't know. Or one has to tick another tickbox in lilypad settings. Unfortunately I need to leave now and can not help you further for the moment. Next time I am on pc will be tomorrow I guess.

I got it to work! I unchecked the box that says "Start without mouse focus" and now it recognizes mouse inputs! I can use the scroll wheel to move through the menu and clicking the LMB acts as the X botton. Thank you so much for your advice and for mentioning the possibility of a focusing problem. Now I just need to play for a little while and see if I actually like my keybindings.
Reply
#8
can someone give me the original controls as you start off in KH2?
ex: shift=square
e=triangle
etc.
also i need to know how map control for camera by moving mouse
Reply
#9
(05-01-2016, 03:25 PM)rampo4823 Wrote: can someone give me the original controls as you start off in KH2?
ex: shift=square
e=triangle
etc.

The picture I uploaded on the original post is what I went with for KH2. I'm still playing around with the original KH to find something I like.
Reply




Users browsing this thread: 1 Guest(s)