Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Massive Slowdowns!
#1
Originally got PCSX2 for Kingdom Hearts 2, which plays beautifully on 1080p btw, but I seem to be getting a slow motion type effect when I try to run any other games.
Anyone have some ideas to fix this? I'd really love to get some other games going!

I apologize if this was already posted, but I got tired of searching.

Current specs: Phenom x4 @ 3.2GHz / GTX 760 gpu / 8gb ram
Reply

Sponsored links

#2
which other games?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
(04-08-2016, 04:00 AM)Nobbs66 Wrote: which other games?

I've tried 3 others so far.
Ratchet and Clank: Deadlocked, Need for Speed: Prostreet, and Mightnight Club 3 Dub Edition

Ratchet and Clank displays full fps but still has significant slowdown
Reply
#4
Any Ratchet & Clank game is slow, on pretty much all systems. Nothing you can do about it.

Pro Street might have a slowdown bug/issue. According to a compatibility report Enabling HW hacks and setting skipdraw to 6 in "Configure Hacks"(in Config - Video (GS) - Plugin Settings) will make it run better.
Reply
#5
(04-08-2016, 08:42 PM)FlatOut Wrote: Any Ratchet & Clank game is slow, on pretty much all systems. Nothing you can do about it.

Pro Street might have a slowdown bug/issue. According to a compatibility report Enabling HW hacks and setting skipdraw to 6 in "Configure Hacks"(in Config - Video (GS) - Plugin Settings) will make it run better.

Well that's a little disappointing but thanks! NFS is running great now!
Reply




Users browsing this thread: 1 Guest(s)