Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Memcard slows down FMV's
#1
Well after a long period of trying to figure out just what was wrong with FMV's playing in Yakuza, i've finally deduced that it was the memcard data I was using. When I disable the memcard, it works perfectly fine. But the question is WHY is it slowing down FMV sequences. I booted up the PS2 BIOS and set all the settings to back how the defaults were, to no avail. Can anyone tell what's going on? I really don't want to beat the whole game again.
Reply

Sponsored links

#2
I don't know for sure but does Yakuza have an auto-save feature? If it does, it might be saving while doing the FMV which could slow it down which would explain why Mem cards are the problem. No Mem Card = No Saving during FMVs

Anyways, activate the memory cards when you need them and disable them when your not.
Reply
#3
As a hackish way around it... you can always load up your memory cards, save with savestates then disable your memory card and use savestates from that point forward.
[Image: 2748844.png]
Reply
#4
This is interesting indeed.
There are a few units in the ps2 that handle memcard accesses, and they all have a way of timing this.
If the timing is wrong, it might make the game code believe there is a problem. The game might then try to
re-access the memory card over and over which in turn causes the slowdowns you get.

So which region is your game? (NTSC or PAL)
Reply
#5
Gee, thanks for the replies. I am using the NTSC copy of the game with the USA BIOS 1.6. Also, I hadn't realized that you can switch the memcards on and off during gameplay, so this should help. So far I know that the same issue occurs on the latest stable release and the latest beta, on both windows and linux.

EDIT: good news, I've fixed it by downloading someone else's save game and replacing the old one with the new one using MYMC. So it was the data itself that must have been corrupted, I still have the bad data in case it serves any interest to the developers.
Reply
#6
I just wanted to say that this bug still exists with Yakuza (the original).

If you load Yakuza with a memory card with a save of Yakuza on it, even the intro from Sega will lag. If you eject the memory card and reset, the lag goes away.

If you save your game onto memory card, and then make a save state; then because you've made the save state after the save, the save state will hold the stuttery FMV's even if you have the memory cards ejected.

If you eject the memory cards after you load, the FMV stutter still exists.

If you insert a memory card with no Yakuza data on it, then no FMV stutter.

So I'd perhaps even propose that somehow the save that PCSX2 makes on the card is wrong so I might try and start again and then make a save with a few variables changed and see if they cause issues. Of course I'll have to make a few new fake memory cards to do this.

Yakuza is a heavily story driven game, so there I expect a lot of cutscenes. I've completed Yakuza 2 and it was filled with it. The first 3 hours of Yakuza 4 had more cutscenes than game time. There's no point in playing Yakuza with this stutter, unless you're trying to 100% the game of course, then I suggest going to the options in game and turning ON skip scene.

Apologies for Necro: I've been doing this a lot recently haha.

Edit: Save "Chapter 1: Go to the fuma family office" does not cause FMV lag. The config data includes really no gameplay and only Widescreen settings. Settings in pcsx2: EE/FPU Round mode: Nearest || Clamping mode: Full

Edit2: Okay. Well I'm at the point where I noticed it lag the first time and it hasn't this time. The three things I changed were I changed the Clamping mode to Full and the Rounding mode to Nearest. The second thing I did was not Overwrite the last save game on the memory card. Finally I made a new memory card.

I'll probably stop checking now as now the game is working I'd like to play it. I waited 2 weeks for this game to ship from the UK.
Reply
#7
I think I experience this on some game before...the game was running little slower because of the memory cards(I'm not talking about the FMVs)

BTW when I start Valkyrie Profile 2 on my PS2 and since I put activity indicator on my 64MB card,I can see that the game is constantly reading from the card when the first fmv is running.
Reply
#8
Just so you know I've nearly finished Yakuza (the original) and starting the game like that has been fine with the saves. Also there have been no game glitches. I'm not sure if a mod could alert someone, but if anyone is interested in further testing I could do that, so that pcsx2 automatically applies settings which will not cause the game-breaking lag in the FMV/cutscenes.

Reply
#9
(06-21-2011, 12:13 PM)skythra Wrote: I just wanted to say that this bug still exists with Yakuza (the original).

If you load Yakuza with a memory card with a save of Yakuza on it, even the intro from Sega will lag. If you eject the memory card and reset, the lag goes away.

If you save your game onto memory card, and then make a save state; then because you've made the save state after the save, the save state will hold the stuttery FMV's even if you have the memory cards ejected.

If you eject the memory cards after you load, the FMV stutter still exists.

If you insert a memory card with no Yakuza data on it, then no FMV stutter.

So I'd perhaps even propose that somehow the save that PCSX2 makes on the card is wrong so I might try and start again and then make a save with a few variables changed and see if they cause issues. Of course I'll have to make a few new fake memory cards to do this.

Yakuza is a heavily story driven game, so there I expect a lot of cutscenes. I've completed Yakuza 2 and it was filled with it. The first 3 hours of Yakuza 4 had more cutscenes than game time. There's no point in playing Yakuza with this stutter, unless you're trying to 100% the game of course, then I suggest going to the options in game and turning ON skip scene.

Apologies for Necro: I've been doing this a lot recently haha.

Edit: Save "Chapter 1: Go to the fuma family office" does not cause FMV lag. The config data includes really no gameplay and only Widescreen settings. Settings in pcsx2: EE/FPU Round mode: Nearest || Clamping mode: Full

Edit2: Okay. Well I'm at the point where I noticed it lag the first time and it hasn't this time. The three things I changed were I changed the Clamping mode to Full and the Rounding mode to Nearest. The second thing I did was not Overwrite the last save game on the memory card. Finally I made a new memory card.

I'll probably stop checking now as now the game is working I'd like to play it. I waited 2 weeks for this game to ship from the UK.

I know I'm kind of recurrecting a dead thread, but this actually fixed the problem I was having in Yakuza. My online question is what exactly do I need to do to save to a memory card without the game screwing up again? I've read the quoted post a number of times, but I'm still confused.
Reply




Users browsing this thread: 1 Guest(s)