Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mercenaries: Playground of Destruction. Scaling Bug.
#1
Posted this in the general section a few months ago, got no responses, dug a bit deeper on my own time, figured I'd try moving it here.

Basically, my issue is fairly simple. Mercenaries 1 is not scaling properly. For some reason, no matter what settings I attempt to apply, it still scales incorrectly, causing screen distortion and tearing.

http://i.imgur.com/mIWnLVK.jpg?1

That is a pretty good example of it in motion. During menus all of the bars are set off, ingame, only a few on the side are, but it can get better or worse depending on various factors ( which don't seem to be consistent at all. )

Specwise, I have a i5-3570K, Radeon HD 7950, and 8 gigs of DDR3 RAM. I originally encountered this issue with PCSX2 build r5350, however I've since moved on to r5594. In an attempt to see if perhaps it's a new issue, as older videos of people playing Mercenaries 1 on PCSX2 seem to not have the issue, I went back and tried r4690 to see if that fixed it, it did not.

In terms of whats going on with my PCSX2 specs. I have AA turned off, and have it set to native. Just in case, I've also set the custom resolution in GS Window to Mercenaries base resolution. None of these fixed the problem. I thought it might be caused by my PC running an HDMI on Overscan, but even dragging out an old DVI cable didn't fix the issue. Oh, and of course I'm running it in Software Mode, as Hardware drops the skybox. I've tried DX9, and DX10 Software, neither changes anything.

Just wondering if there is something simple I'm missing here. Downloading PCSX2 v 1.0 to see if it works on that, but I'm guessing it'll have it's own issues.
Reply

Sponsored links

#2
scaling isn't an emulation issue, games are prone to problems when using scaling. Moving to the support section.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Have you tried a custom aspect ratio or have you only used native multipliers?
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#4
(04-05-2013, 10:21 AM)Dante3hs Wrote: Have you tried a custom aspect ratio or have you only used native multipliers?

Only did fit to screen, 4:3, and 16:9. None of them fixed the issue.

How would one set a custom aspect ratio?
Reply
#5
In your gsdx settings. I meant resolution, not aspect ratio, my bad.
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#6
(04-05-2013, 01:33 PM)Dante3hs Wrote: In your gsdx settings. I meant resolution, not aspect ratio, my bad.

Ah yeah, tried a few. None of them seemed to work, but Hardware mode in this game is really messed up, so it's hard to tell if they didn't work because of that, or just because they didn't fix the issue.
Reply
#7
So I fiddled around with Hardware mode a bit. If I go to the GSDx plugin, and turn on Hardware, one of the options is to change Scaling.

At 2x and 4x Scaling, the problem is fixed entirely. The new problem is of course Hardware lacks the Skybox, and a whole host of other issues.

Is there a way to force 2x native scaling in Software mode?
Reply
#8
(04-07-2013, 12:48 AM)Default137 Wrote: So I fiddled around with Hardware mode a bit. If I go to the GSDx plugin, and turn on Hardware, one of the options is to change Scaling.

At 2x and 4x Scaling, the problem is fixed entirely. The new problem is of course Hardware lacks the Skybox, and a whole host of other issues.

Is there a way to force 2x native scaling in Software mode?

Nope, the best you can do is enable the edge AA method. Software mode is just for compatibility (as it's supposed to emulate the PS2 display 1:1). Even if there was a software method to do rendering at 2x, you'd be looking at close to 4x the CPU requirements to achieve it.
[Image: 2748844.png]
Reply




Users browsing this thread: 1 Guest(s)