Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Messed up previous install and future ones
#1
Yesterday I installed pcsx2 1.2.1 from the site, went though the configuration following the guide, and everything was going fine and working great. Once I got a few games going the way I wanted to I thought I'd put shortcuts for them on steam.

I did it using the way described here http://forums.pcsx2.net/Thread-Auto-Boot...Separately and everything worked fine UNTIL I accidentally directed the cfgpath to an empty folder I had created instead of copying and renaming.

After I had done that, I went to play the game before noticing what I had done. Game started up fine but once it did none of the controller inputs worked. I exited pcsx2, found what I had done, fixed it by copying the inis file I had been using before, and changed the cfgpath to it instead of the empty folder. Started up pcsx2 again, same problem. Went to check my plugins thinking it was my controller. When I opened the plugin window this came up in the program log:

[wx] Failed to load shared library 'C:\Emulators_and_Ice\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll' (error -1073741795: unknown error c000001d)
Path: C:\Emulators_and_Ice\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Emulators_and_Ice\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll

I went into LilyPad config and tested my device, the 360 controller was working fine. I did a complete uninstall (including plugins) and then did a fresh install, went through first time config, went to load a game, starts up fine, but, once again, the controller input wasn't responding.

Was wondering if this was something I could fix or if I just messed up everything right bad.

specs:
Model: Alienware AURORA_R4
Processor: Intel® Core™ i7-3930k CPU @ 3.20GHz 3.20GHz
Installed Memory (RAM): 16.0 GB
System type: 64-bit Operating System
Reply

Sponsored links

#2
Try the GIT one: http://forums.pcsx2.net/Thread-PCSX2-GIT-Weekly-Builds
If that doesn't work then there's something wrong with your controller.
[Insert Witty Sig Here.]
Reply
#3
(06-28-2014, 05:35 PM)KeyToTruth12 Wrote: Try the GIT one: http://forums.pcsx2.net/Thread-PCSX2-GIT-Weekly-Builds
If that doesn't work then there's something wrong with your controller.

??
As if there would be a difference between GIT and stable release concerning the current problem.

(06-28-2014, 05:06 PM)Scotia Wrote: [wx] Failed to load shared library 'C:\Emulators_and_Ice\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll' (error -1073741795: unknown error c000001d)
Path: C:\Emulators_and_Ice\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll
File is not a valid dynamic library.
Some kinda plugin failure: C:\Emulators_and_Ice\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll

The plugin error is normal since your cpu doesn't support avx2.

Can you please clarify:
You controller is working or not if you run the gui normally?
Are you sure that the cfg-path (the flag and the folder itself) are really written correctly?
Do you use special chars in your cfg-path?
Reply
#4
When I reinstalled it I did not remake any of the shortcuts or attempt to use cfg paths. I did not use special characters in the cfg paths or object names when I made them the first time. I just used the release as it was after setting the configurations to the suggested ones in the guide.

From a clean install: The controller works when tested in plugin window with lilypad, but once an iso is loaded pcsx2 stops responding to the controller. (ie when a game says "press start" and I press start nothing happens and it goes to the usual movie or w/e they have when start isn't hit after a while. Any button pressed during the movie that would usually return you to the "press start" does not work)
Reply
#5
(06-28-2014, 05:35 PM)KeyToTruth12 Wrote: Try the GIT one: http://forums.pcsx2.net/Thread-PCSX2-GIT-Weekly-Builds
If that doesn't work then there's something wrong with your controller.

I have done this, the xpad plugin that comes with it solved my problem, the controller responds once a game starts, thank you! This was the only plugin for the pad that isn't in the 1.2.1 release. The problem still persists if I set the pad to any of the plugins for the pad from 1.2.1. When I had messed up the cfg path and set it to an empty folder, could this have affected the drivers/programs for my controller so that it no longer worked with the other drivers? I did not reinstall or uninstall anything regarding my controller (though I did unplug it and plug it in to see if that was it)
Reply
#6
Nope, only the cfg.
[Insert Witty Sig Here.]
Reply
#7
(06-28-2014, 07:45 PM)Scotia Wrote: From a clean install: The controller works when tested in plugin window with lilypad, but once an iso is loaded pcsx2 stops responding to the controller.

Sounds like you forgot mapping the input to ps2 buttons.
Reply




Users browsing this thread: 1 Guest(s)