Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 2 + 3 Run Slow
#1
Hi Laugh

I first attempted to play MGS 3 but the game played in slow motion (around 20-30 fps if I remember right). I initially thought my computer wasn't fast enough to run it. I downloaded MGS 2 thinking that it would it would be less hard on the computer. Still slow motion. Must be my emulator settings. I messed around with speed hacks a little, no improvement.

I don't know much about emulators, I just download them and mess around with them until they let me run my games. I have successfully played Final Fantasy X so far on pcsx2.

Computer:
AMD Athlon X2 645 processor
AMD Radeon 7750 video card
8g RAM

Emulator Settings:

   
   
   
   
   
   
   

Let me know if you need any other info to help me out. I really want to play these two games. Thanks a ton in advance.
Reply

Sponsored links

#2
(10-08-2012, 02:18 PM)hunterkil2 Wrote: I downloaded MGS 2 thinking that it would it would be less hard on the computer.

Firstly, delete this game you downloaded, this is illegal and it won't be tollerated here.

As for your slowness problem, the issue is your CPU. the Athlon X2 is an old and very slow processor. You will need a decent modern processor to run these games at a good speed.

on an i7 920 quad core @ 3.4Ghz i can run mgs3 at full speed, but only just. A Sandybridge i5 at similar speeds would probably be even quicker.

All you can do for now is tick the "Native" box on the gsdx config and possibly try a couple of speedhacks.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
I am very sorry about the issue with downloaded content. I was merely checking it against MGS 3 and will delete it immediately.

Also, my apologies. It is AMD Athlon X4 645. Not actually an old processor.
Reply
#4
nice :-)

i also played final fantasy x and then i played final fantasy x-2. i am now playing metal gear solid 3: snake eater

try changing the graphics plug in to the following:-
   
   

use the dx11 one if u have it. if not use dx9. click native resolution. it gives u a speed boost i think

if u want u can turn on speed hacks and mess with it carefully

my advice is play metal gear solid 2 for pc then play snake eater for ps2
Reply
#5
okay firstly, update your emulator to 1.0.0 or the latest svn.

then under speedhacks, tick the idle loop detection, INTC hack and MTVU (this will take advantage of your 3rd core) and turn the rest of the hacks off.

see if that's any better along with the above advice.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#6
Changed it to dx11 and it works great. Didn't have to change anything else. Thanks!
Reply
#7
good :-)

turn on native resolution
Reply
#8
You will probably have points of slowdown unless you enable MTVU, id suggest putting that on anyway Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
well i've been messing around with everything. Native seems to make it slower, not sure why. Turned on speed hacks and it runs fairly well. There are points of slowness still. Not too bad, definitely better.
Reply
#10
LOL can't believe you gave support to a pirate.
Intel Core i3 3.1 GHz
4 GB of RAM
Geforce GT 440 1 GB DDR3
Windows 7 HE x86
Reply




Users browsing this thread: 1 Guest(s)