Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 2 Thermal Goggles Screen Problem
#1
Hello. I've been using various builds from the official 0.9.6 to beta builds like r1736, r1888, etc (yes I know there is no beta support). Beta build r1736 has worked wonders for me over the official 0.9.6, but I still alternate both to try to resolve problems in-game or try other configurations. I've only had slight issues with a few games as my computer handles emulation remarkably well, but I've encountered a strange graphical issue making Sons of Liberty harder than it should be. I have no problems using Scopes or Nightvision Goggles, but when Thermal Goggles are used, the screen seen is something like this:

[Image: thermalgogglesscreen.jpg]

I'm sure someone has encountered this before or knows what this issue is. My specs are below:

Windows 6.0.6002 (Service Pack 2 2.0)
NVIDIA GeForce 9500 GS (8.16.11.9062)
Intel® Core™2 Quad CPU Q6700 @ 2.66GHz (Quad Core)
6 GB RAM
SSE2 and SSSE2 are both detected, no 4.1
Windows Vista 64-bit
All C++ visuals updated including latest DirectX

0.9.6 Config:
GSdx 890 (MSVC 15.00, SSSE3) 0.1.14
-Direct3D 10 Hardware
-Interlacing: Blend tff (slight blur, 1/2 fps) <-- tried all kinds and without
-D3D internal res: Native
SPU2-X 1.1.0
SSSPSX PAD Plugin Pressure Mod 1.7.0
EFP Iso CDVD Driver 0.6.0

CPU:
-MTGS on, EERec checked with VU Recompilers both checked

Speedhacks:
-None

Advanced:
-EE Recs Options-
Round Mode - Chop / Zero
Clamp Mode - Extra + Preserve Sign
Denormals are Zero checked
-VU Recs Options-
Round Mode - Chop / Zero
Clamp Mode - Extra
Denormals are Zero checked

I hope I didn't give too much unneeded info :x I wonder if there is a fix found if I could apply it to PCSX2 r1736 as well ;x It seems to be the most stable for me. Remember, I'm asking for 0.9.6 help mainly not beta.
Reply

Sponsored links

#2
At least 38 views and 12 hours without a bite o.o :x Can a girl get some assistance? ~.^
Reply
#3
Try a software renderer in GSdx, setting the clamp modes in advanced options to normal and check/uncheck microVU in CPU options in the beta.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
Thanks for the response ^^ I tried all of those in every possible combination and got the same result ;.;
Reply
#5
Update: I tried older versions and different plugins.. I get the same effect Sad... Everything else is fine except the Thermal Goggles screen.. Help qq
Reply
#6
Microvu is fixing this bug I think, but I'm not sure.
CPU: Intel Core i7 3770s 3.1 GHz (Turbo 3.9 GHz)
GPU: Nvidia GeForce GTX 980 4096 MB
RAM: 8192 MB DDR3
MOBO: Asus P8Z77-V LK
OS: Windows 8.1 Pro with Media Center 64-bit
Reply
#7
I tried all options with checking/unchecking microvu.. nothing.. however I've been encountering something strange of the console screen which I'm wondering if it could be related. I get the following message:

microVU0: Cached MicroPrograms = [001] [001]
microVU0: M-bit set!
microVU0: M-bit set!
microVU0: M-bit set!
microVU0: Cached MicroPrograms = [002] [002]
microVU0: Cached MicroPrograms = [003] [003]
microVU0: Cached MicroPrograms = [004] [004]
microVU0 Warning: Branch, Branch, Branch! [05c8]
microVU0: Cached MicroPrograms = [005] [005]
microVU0: Cached MicroPrograms = [006] [006]
microVU0: Cached MicroPrograms = [007] [007]
microVU0: Cached MicroPrograms = [008] [008]
microVU0: Cached MicroPrograms = [001] [007]
microVU1: Cached MicroPrograms = [002] [002]
microVU1: Cached MicroPrograms = [003] [003]
microVU1: Cached MicroPrograms = [004] [004]
microVU1: Cached MicroPrograms = [005] [005]
microVU1: Cached MicroPrograms = [006] [006]
microVU1: Cached MicroPrograms = [007] [007]

The microVU0 Warning is in red. The rest is in yellow except for the M-bit set lines in green. Any idea if it is related?
Reply
#8
Update: I acquired a software plugin from a new beta build which I could use and get through. Lock the thread I guess unless the microVU0 can be explained first.
Reply
#9
I have the same problem too . It would be very frustrating if I'll have to abandon the game now after going so far . So , please , could you tell me what was that plugin that you used ?
Reply
#10
Press F9 while playing to switch to the sw renderer.
Reply




Users browsing this thread: 1 Guest(s)