Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 2 on PCSX2 runs slow
#1
I cannot get a constant 50 fps in MGS2(pal) on PCSX2 0.9.7 (r3113) during gameplay and some cut scenes fps drops to 40-30
CPU: intel i3 540 3.06ghz
GPU: nvidia geforce 250gts 1gb
RAM 2gb ddr3
OS is Windows 7
I tried to use some speed hacks but they don't give any results
[Image: ad7c9423dbea.jpg]
this is plugins all they settings are on default right now
Reply

Sponsored links

#2
That's about double the FPS I get in MGS3... lmao.

This is a really CPU intense game, your probably better off playing the PC port or something.

Then again, if you were able to overclock you could nudge your processor up to the speed needed to keep the framerate constant at the frame limiter most of the time.
CPU: Pentium D 'Presler' 915 2.8 ghz 2x2MB L2 @ 3.5 ghz
GPU: eVGA [Nvidia] 8600GT 256MB SSC DDR3
Tested: FFX, FFX-2, FFXII, MGS3, KH, KH2, The Hobbit NTSC
PCSX2 FTW! Biggrin
Reply
#3
(08-29-2010, 06:50 AM)Dangerousd777 Wrote: That's about double the FPS I get in MGS3... lmao.

This is a really CPU intense game, your probably better off playing the PC port or something.

Then again, if you were able to overclock you could nudge your processor up to the speed needed to keep the framerate constant at the frame limiter most of the time.

I played a PC port and he give me only a graphics full of glitches and inability to set controls properly. About overlocking - yes I can try it if anything else wont work, i just very afraid to damage my processor, I just need a 10-20 fps more to play this game comfortably, can you advice a good speed hack config or some patch?
Reply
#4
You won't damage your processor if A. it does not reach over 65-70 celsius for long periods of time and B. you don't increase voltage.

My processor has been through everything, even 75 C for hours and hours at 4 ghz, and yet runs error-free. Rolleyes
CPU: Pentium D 'Presler' 915 2.8 ghz 2x2MB L2 @ 3.5 ghz
GPU: eVGA [Nvidia] 8600GT 256MB SSC DDR3
Tested: FFX, FFX-2, FFXII, MGS3, KH, KH2, The Hobbit NTSC
PCSX2 FTW! Biggrin
Reply
#5
deleted
jesalvein broke my balls, farewell
Reply
#6
on the slow scenes switch to software mode by pressing F9, the slowdown in this game is caused by the video card no being fast enough (core)

btw this thread is old next time make your own thread.
Intel Core I7 930@3.5GHz(TB, HT), 6GB DDR3@1600MHz, Geforce 970 G1
Reply
#7
(03-19-2012, 09:54 AM)CobraSA Wrote: Sorry to bump this old thread, but it's the only one I found on topic.
Still no speed hack for Metal Gear Solid 2? Runs too slow 45FPS and frame skipping doesn't really help.

have you tried VU cycle stealing at LV-2 aside from frameskipping??
anyway i think there is no hope yet to get the entire gameplay at Vmax speeds
i got knockdowned-framerate from 64Fps to 4~6FPS during cutscene where the harrier was rescured by a MG-RAY so i hurried hitting start or X button to skip that nasty KOed framerate.
my specs currently on my siggy.
Main Hub:i5-4670(3.4Ghz Factory Clocked),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#8
Quad core owners should be using the MTVU hack in the latest svn`s http://buildbot.orphis.net/pcsx2/
And set extra render threads to 4-5 in gsdx
ROG Asus G74S laptop
Intel core i7 2670QM @2.2(3.1ghz turbo) Nvidia 3gig GTX560m 8 gigs DDr5 Blue-Ray Burner windows7 64 bit
[Image: r1gyld.jpg]
Reply
#9
deleted
jesalvein broke my balls, farewell
Reply
#10
did you try to disable crossfire ?
AFAIK, pcsx2 doesn't handle it.
Quote:I run the latest games in AAA mode very easily.
which ones ?if you're talking about SVR2012, I don't think t's THAT GPU demanding...
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)