Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 2 runs very slow on PCSX2 1.0.0
#1
my PC:
Athlon II-X4 3GHz
RAM 2x2GB 1600MHz
HD4770

i get 90+ fps on Splinter Cell : Double Agent, Harvest Moon AWL, Bloody Roar 4, etc.

but why it runs very slow? since change log on PCSX2 1.0.0 says,
"microVU fixes for Metal Gear Solid 2 and others"
Reply

Sponsored links

#2
MGS is a very demanding game. I suggest you use the MTVU speedhack along with the recommended ones, that should help you out a bit Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
hopefully you should get around 60 fps during the gameplay, but during the cutscenes the speed drops to around 30 fps in some parts of the cutscene, but once that part is over the speed will go back to 60 fps. i played metal gear solid 3 and i got many slowdowns in it and metal gear solid 3 is as heavy as metal gear solid 2
Reply
#4
(11-22-2012, 11:44 AM)refraction Wrote: MGS is a very demanding game. I suggest you use the MTVU speedhack along with the recommended ones, that should help you out a bit Smile

i did, but it stay 40-45 fps which is slow motion during gameplay, unplayable to me

(11-22-2012, 12:45 PM)solidus Wrote: hopefully you should get around 60 fps during the gameplay, but during the cutscenes the speed drops to around 30 fps in some parts of the cutscene, but once that part is over the speed will go back to 60 fps. i played metal gear solid 3 and i got many slowdowns in it and metal gear solid 3 is as heavy as metal gear solid 2

i got playable fps on MGS3 (35-40 cutscene, 50-60 gameplay)
but not in MGS2 (30-40 cutscene, 40-45 gameplay which is unplayable)
Reply
#5
OC your cpu (700+ mhz)
Reply
#6
Play the PC version.
Intel Core 2 Quad Q9400 | nVidia GeForce GTX 750 | 4 GiB DDR3 @ 533 Mhz | MSI G41M-P28 | Cooler Master RS-390-PMSR-A3 | Xigmatek TYR SD962 | LG Flatron W1943SE | HP KB-0316 | MotoSpeed F60
Reply
#7
playing the pc version is not as easy as you think. i know from experience. you are not able to play it on vista and windows 7 and there are bugs when using radeon and nvidia cards. there are steps that u have to do to get the game to run. see this link:-
http://mgsforums.com/topic/7412109/1/

it has instructions. basically you have to download a zip file which contains a patch file and .exe files. patch the game then overwrite the .exe files in order to fix the graphical glitch problem. also in the zip file is a program called alchemy which u have to install. alchemy fixes the sound compatibility problem

after that the game should run ok. in the intro of the game there is a scene in which snake talks to otacon on the codec. the codec screen is gray and you can't see their faces. patching the game and overwriting the .exe files should fix this bug

if you are still facing glitches then try these:-
Quote:Alright I've been playing around a bit and now I know what causes the error...It's the model quality setting.
You can set everything to whatever you want except for the model quality. The graphic bug occurs when you set the model quality to 4/4 (highest) or 3/4 (second highest)...if set to 2/4 (second lowest) or 1/4 (lowest) everything should work fine and if the other graphic settings are set to high the game will still look great for a 2003 game =)

and

Quote:dont know if most of you found out by now but if your screen is green/black go to options (Launcher) not the in game option and click the "Draw" tab and slide the knob to about the 6th notch from the left maybe the 5th but it'll clear up the screen for sure !!!!
Reply
#8
MGS2 needs a lot of memory bandwidth on the GPU. The only thing you could try is to reduce the internal resolution to 2x or Native and activate the "Allow 8-bit textures" setting in GSDX.
The CPU should be ok with the MTVU hack on for the most parts.
Reply




Users browsing this thread: 1 Guest(s)