Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 3 configuration help?
#1
Specs: Windows 8, 64 bit.
8 GB ram
eight-core processor
Graphics card: Asus r9 270x

So, whenever I run MGS, I still get low frame rates to anywhere from 30-40 fps (usually during a lot of the cut scenes) which is alright since even the original PS2 had frame-rate issues with the game. But, the sound always sounds like its being ***** up the ass, and its especially noticable when a song is playing in the background. The PS2 never did this "slow-motion" effect for low frame rates, so how do I remove this?

Proof that the ps2 didnt do the gay annoying slow motion ***** pcsx2 does during low frame rates: https://www.youtube.com/watch?v=poEqykRrxDk

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
- Your hardware specs - CPU, Graphics Card, Memory, Operating System.
- The version of PCSX2 you are using.
- Any non default settings you are using.
- What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
[Insert Witty Sig Here.]
#3
Everything that you just said was provided, except for my settings. As for what version of PCSX2 I'm using, it should be pretty obvious that im running the latest one (PCSX2 1.2.1).

The only setting I changed was my renderer, which I set to Direct3D11 (Hardware). I also turned off texture filtering and I set my audio module to xaudio2
#4
No it's not obvious, since there are probably close to a thousand git revisions since 1.2.1

Also, an 8 core CPU is incredibly vague, as there are quite a few of them out there.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
#5
AMD FX-8350
#6
Single Thread Rating of 1500 in Performance Test 8. It's a synthetic benchmark, but it gives a decent idea as to how a chip will perform in PCSX2.

You'll need a good cooler to get a clock speed high enough for that game. 4.7ghz+ is what I'd try to hit.


Edit: You'll still get slowdowns with that chip. It's not exactly that great for emulation due to the low single thread performance.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
#7
LOL, seriously f uck you.

I just fixed the problem thanks to this video: *snip*

Seriously, f uck people like you that go on these forums. There's seriously no reason to overclock my 8-cores just to run this game, especially when theres people with only 3 or 4 cores running the game perfectly without overclocking their systems. All I had to do was turn on some speedhacks and mess with the audio settings a little bit, and it's hilarious how you people always jump to conclusions thinking that our PCs specs need to be upgraded/overclocked. Dumb ass. Seriously how stupid can you people get?

Edit: Also, I suggest subscribing to this dudes channel, he saved me from actually overclocking my system even though it was completely unnecessary.
#8
If you think you'll get full speed 100% of the time, we'll see...

Async Mix also doesn't change the game speed. It just doesn't sync the emulated SPUs with the rest of the PS2. Not sure how IRQs work for timing like that though.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
#9
I'm not expecting full speed 100% 60 fps 24/7 on MGS3, I just wanted to fix the slow-motion audio, but so far my FPS has been at 60, even through some of the cutscenes that the ps2 could barely scrape by handling. No over-clocking was neccessary was my point. I suggest you and the other forum mods on here stop suggesting it everytime someone has an issue with their emulation. Seriously. Read their question first, and if you're not sure don't just jump to conclusions.
#10
Since you already fixed your problem, we don't need this thread open anymore. Also, have a warning for flaming.




Users browsing this thread: 1 Guest(s)