Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Metal Gear Solid 3 crashes and freezes
#1
I've been trying to play MGS3 and have been running into some major issues. It seems when walking into specific areas of the game, PCSX2 will stop responding or the game will lock up and freeze after being in that area for a few seconds. This was most notably in the swap area with the crocodiles, which through luck I managed to run through and get out of before the game could crash. Now however, it's happening again at the area surrounding the cave that EVA tells you to go in, so I can't progress at all.

I've been trying all day with numerous fixes, nothings working. Can anyone help?
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
(10-01-2015, 08:14 PM)Blyss Sarania Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.

Intel Core i7 4770k
NVIDIA Geforce 770
8gb RAM
Windows 10

PCSX2 version 1.2.1

I'm using GSdx ssse3 and Direct3D11 (Hardware), apart from that all default, and I'm playing off an ISO.
Reply
#4
Try latest PCSX2 from http://buildbot.orphis.net/pcsx2

Also why SSSE3? That CPU supports AVX2 which would be better.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
think about posting the emulog.txt after it crashes too
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
(10-01-2015, 08:34 PM)Blyss Sarania Wrote: Try latest PCSX2 from http://buildbot.orphis.net/pcsx2

Also why SSSE3? That CPU supports AVX2 which would be better.

Oh, I didn't know. It didn't fix my problem when I tried using it, but if it's better I guess i'll use it.
I did download 1.3.1 to see if that would fix it, but my saves didn't work, so I think I transferred them incorrectly. I will try this, but how do I transfer savestates? (if it's even possible to transfer saves between versions)
Reply
#7
It isn't possible.
Emulog, please ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
(10-01-2015, 08:46 PM)jesalvein Wrote: think about posting the emulog.txt after it crashes too
Sure thing.


(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.59;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SLUS_213.59;1) Game CRC = 0x053D2239, EntryPoint = 0x00852A68
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLUS_213.59;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = NTSC

IOP Realtime Kernel Ver.0.9.1
Copyright 1999 © Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLUS_213.59;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLUS_213.59;1
0 00800000 00055ef8 ......
Loaded, cdrom0:¥SLUS_213.59;1
start address 0x852a68
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
Copyright 1999-2002 © Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 ©SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadmodule: fname cdrom0:¥MODULES¥PLD.IRX;1 args 9 arg 00d20000
USB Driver (Version 1.4.0)
loadmodule: id 25, ret 1
Loading savestate from slot 0...
filename: C:\Users\user\Documents\PCSX2\sstates\SLUS-21359 (053D2239).00.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2
MTVU speedhack is enabled, saved states may not be stable
(EE pc:001512A4) TLB Miss, addr=0x2f2f8022 [load]
(EE pc:001512A4) TLB Miss, addr=0x2f2f8032 [load]
(EE pc:001512A4) TLB Miss, addr=0x2f2f8042 [load]
(EE pc:001512A4) TLB Miss, addr=0x2f2f8052 [load]
(EE pc:001512A4) TLB Miss, addr=0xf0e8018 [load]
(EE pc:001512A4) TLB Miss, addr=0xf0e8028 [load]
(EE pc:001512A4) TLB Miss, addr=0xf0e8038 [load]
(EE pc:001512A4) TLB Miss, addr=0xf0e8048 [load]
(EE pc:001512A4) TLB Miss, addr=0x18188016 [load]
(EE pc:001512A4) TLB Miss, addr=0x18188026 [load]
(EE pc:001512A4) TLB Miss, addr=0x18188036 [load]
(EE pc:001512A4) TLB Miss, addr=0x18188046 [load]
(EE pc:001512A4) TLB Miss, addr=0x17288020 [load]
(EE pc:001512A4) TLB Miss, addr=0x17288030 [load]
(EE pc:001512A4) TLB Miss, addr=0x17288040 [load]
(EE pc:001512A4) TLB Miss, addr=0x17288050 [load]
(EE pc:001512A4) TLB Miss, addr=0x25308023 [load]
(EE pc:001512A4) TLB Miss, addr=0x25308033 [load]
(EE pc:001512A4) TLB Miss, addr=0x25308043 [load]
(EE pc:001512A4) TLB Miss, addr=0x25308053 [load]
(EE pc:001512A4) TLB Miss, addr=0x18208017 [load]
(EE pc:001512A4) TLB Miss, addr=0x18208027 [load]
(EE pc:001512A4) TLB Miss, addr=0x18208037 [load]
(EE pc:001512A4) TLB Miss, addr=0x18208047 [load]
(EE pc:001512A4) TLB Miss, addr=0x1b1b8013 [load]
(EE pc:001512A4) TLB Miss, addr=0x1b1b8023 [load]
(EE pc:001512A4) TLB Miss, addr=0x1b1b8033 [load]
(EE pc:001512A4) TLB Miss, addr=0x1b1b8043 [load]
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
* SPU2-X: Waiting for DSound thread to finish... Done.
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
Reply
#9
You need to make a memory card save and load from that.

See the link in my signature(General FAQ), section about save states.

If that doesn't fix it then remake your ISO with imgburn.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#10
(10-01-2015, 09:10 PM)Blyss Sarania Wrote: You need to make a memory card save and load from that.

See the link in my signature(General FAQ), section about save states.

If that doesn't fix it then remake your ISO with imgburn.

I just moved the memory card save over to 1.3.1, and I seem to be able to enter the area now. Hopefully this remains consistent. Thanks!
Reply




Users browsing this thread: 1 Guest(s)