Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Mortal Kombat Shaolin Monks - awful sound
#1
Hi, I'm using gdsx sse2 video plugin (my computer doesn't support sse3 and 4) and SPU2 - X sound plugin. With speedhacks I have something about 35 fps and the sound is very nice. Without speedhacks I have 45-50 fps, but the sound is veeeery sloooow, it sounds really bad. What can I do about it? I tried timestretch and "audio can skip" functions, but on the second one Liu Kang sounds like a monkey - u-u-u-u-u-a-a-a-a. What can I do about it? I repeat, on 35 fps the sound is good, but on 45-50 fps (without speedhacks) it's terrible.

EDIT

Also, is there any way to use "constant skipping" function without awful graphical errors? I found out that "10 frames to draw" and "10 frames to skip" is an option almost without artifacts, on 2,2 I have 81 fps, but the screen blinks all the time and it's hard to watch because of the graphical bugs. Also, the sound is still awful even with 81 fps and it's slower than what I can see on the screen, I hope that you understand me.
With speedhack VU Cycle Stealing turned on 3 and constant skipping the sound is great, but the graphical errors are a lot worse and I can barely see anything.
Reply

Sponsored links

#2
Nobody has this problem? The sound is bad with the recommend speedhacks and without them, only VU Cycle Stealing makes it good, but it slows down the game. With 95% speed the sound is too slow, the characters cuts their speeches to say something else, because the screen is smooth while the sound is slow. I tried many sound settings and different plugins, but the effect is even worse.
Reply
#3
PC specs? PCSX2 settings? Plugin settings? What are the EE/GS% numbers in the game window say when you get slowdowns?

Sound in the game is not awful, you're simply not getting enough speed for it and since you tried speedhacks already then I doubt there's much you can do about it. You could try setting SPU2-X's synchronizing mode to "Async" but it will go out of sync in cutscenes if you still don't get full speed.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#4
My computer specs: WinXP SP3, 4 ghz dual core, 3,6 gb ram, nvidia geforce 9600gs, DirectX 9.0c.
Plugin settings: everything on default. Changing the resolution to native doesn't help.
PCSX2 settings: everything on default, except for VU0 and VU1, I'm using SuperVU, but the problem is also on default MicroVU.
EE numbers: with speedhacks 54-75%, without speedhacks and with constant skipping 2,3 I get 95-98%, the GS is 69-97% (I know, it's a huge variance, but it doesn't affect the game's speed. I mean the screen speed), 70 fps.
Quote:Sound in the game is not awful, you're simply not getting enough speed for it
As I said - with speedhacks the game is slower, but the sound is great. It's slowed down, but it sounds good. Without speedhacks the sound is even slower, while the screen runs in full speed, and I can also hear a strange sound, like a motorbike or something like that, it sounds like the emulator uses strange filter for the sound. So it's not only slowed down, it has also really bad quality. So it's not a game speed's fault, because it works in full speed. I tried many settings in the sound plugin, but it didn't help.
Reply
#5
Yeah, speedhacks can cause fake FPS (apparent full speed but slower game as you mentioned), out of sync audio (again faster audio but the game itself is slow) and other things as it's mentioned in the Speedhacks panel, when you mention it sounds great when the game is slow it means the audio is fine as soon as it gets full speed, which currently you only get when getting the fake FPS from thespeedhacks. I suggest you try each speedhack one by one and find a good combination or at least post a screenshot of which you're using at the moment.

Did you try Async synchronizing already? What were the results?
Which CPU do you have?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Reply
#6
Thanks, it sounds good on Async. It's still not perfect, because sometimes I can hear some sounds twice ("what are those creatures? What are those creatures?"). Also, when I'm minimizng the game and maxymazing it again, the sound is delayed for about 2 seconds according to the screen. But thanks, at least it sounds good now, it's not slowed down and it has good quality.
Is there any way to use constant skipping without constant blinking and graphic bugs? The screen is brighter and then darker every milisecond, also some objects disappear and then appear again, so it's hard to watch, but it gives me a full speed of the game, so it's very useful.
Reply




Users browsing this thread: 1 Guest(s)