Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Movement In-Game is Choppy and Seems to be Set to Specific Angles
#1
I recently bought a PS2 controller so that I could play some of my emulated games properly. Initially, there was an issue with the D-Pad, which I fixed after some tinkering and a new driver installation. After I'd done that I decided to take the controller for a test drive, so I booted up Gitaroo Man and started the first mission. As soon as I moved the left analog stick I noticed that whenever I moved it the pointer in game would stick to an angle that was  loosely related to the direction I'd intended to move it to. It did this for every direction. I tried adjusting the sensitivity but it didn't help anything. 

Is there any way to fix this?


Thanks in advance.
Reply

Sponsored links

#2
Try setting the x&y sensitivities to 1.256. Remember. This is an emulator. it can't be super precise the way the actual hardware can.

Tho. Considering everything. You should already have had a controller,
[Image: dy6224-5.png]
Reply
#3
(12-17-2016, 03:19 AM)rikimaruaxu Wrote: Try setting the x&y sensitivities to 1.256. Remember. This is an emulator. it can't be super precise the way the actual hardware can.

Tho. Considering everything. You should already have had a controller,

I adjusted the sensitivity to 1.256 and it didn't fix the issue. It only made the controller snap to certain angles faster.


And, on a sort-of side note, I was using an XBox 360 controller prior, and the movement was much smoother then, but the design wasn't really compatible with Gitaroo Man so I bought a  brand-new PS2 controller so I could play properly.
Reply
#4
The only thing I can think of is that maybe the controller is a fake DS2, Cause ps2 controllers are analog. and this issue makes the analog sticks seem digital. Can you get full movement in the controller panel "Control panel/Devices and Printers, right click the controller. click game controller settings/properties and see if the right analog stick has full movement there. instead of 2 bars that slide back and forth.
[Image: dy6224-5.png]
Reply
#5
(12-17-2016, 11:21 AM)rikimaruaxu Wrote: The only thing I can think of is that maybe the controller is a fake DS2, Cause ps2 controllers are analog. and this issue makes the analog sticks seem digital. Can you get full movement in the controller panel "Control panel/Devices and Printers, right click the controller. click game controller settings/properties and see if the right analog stick has full movement there. instead of 2 bars that slide back and forth.

I tested it out there and it seems to be just as sticky and unresponsive there as well. I tried re calibrating it but it didn't seem to change anything. However, I did install a driver to fix the issue I had with the D-Pad, which makes windows read the PS2 controller as an X-Box 360 controller and (I think) handle it as such. Could that be the root of the problem?

In regards to the 2 bars back and forth, I'm not exactly sure what you mean by that. There's three that seem to judge sensitivity, and there's a square with a cross in the center that moves, albeit choppily, whenever I move the left analog.
Reply
#6
Have you tried the controller on your PS2 to see if it has the same issues?
Reply
#7
What driver did you install to make windows think its a xbox 360 controller? Some of them are just terrible. Also how are you connecting your PS2 controller to PC? AKA what device are you using?
Reply
#8
(12-17-2016, 11:04 PM)Topken Wrote: What driver did you install to make windows think its a xbox 360 controller? Some of them are just terrible. Also how are you connecting your PS2 controller to PC? AKA what device are you using?


http://forums.pcsx2.net/Thread-XInput-Wr...Controller is the driver.

https://www.amazon.com/gp/product/B000YM...UTF8&psc=1 is the adapter I'm using to hook it up to my computer's frontal USB port.
Reply
#9
(12-17-2016, 09:03 PM)FlatOut Wrote: Have you tried the controller on your PS2 to see if it has the same issues?

I put my PS2 in storage and my TV isn't hooked up currently, and I don't have anything else I could plug it into even if I were to go and pick it back up, so sadly I don't think I'll be able to test it on that.
Reply
#10
I think your problem is probably the same Dark Souls 2 has (it needs a deadzone and antideadzone tweaking). http://www.nexusmods.com/darksouls2/mods/76/?

Kingdom Hearts 2 has that problem too. I've tried that Durazno program and also the Pokopom pad plugin (which has its own deadzone and antideadzone settings), but I couldn't find a configuration that fixes movement.
CPU: Intel Core i7 7700k @ 5GHz
GPU: Gainward GTX 1080 GLH
Motherboard: Gigabyte Aorus GA-Z270X-Gaming 5
RAM: G.Skill Trident Z RGB DDR4 3866MHz 16GB CL18
Monitor: Dell S2716DG
OS: Windows 10
Reply




Users browsing this thread: 1 Guest(s)