Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Multiple Games Help
I have some problems with a couple of games, first of all this is my machine:
AMD Athlon 64 X2 Dual Core Processor 6000+ 3.01GHz.
2Gbs Of RAM.
GeForce 9400Gt 512Mb.
Windows Xp SP 3.
Forceware 195.62.
Direct 9.

Final Fantasy X arround 35fps during all times and 11fps During the killing of monsters, entering battles and summoning aeons.

Final Fantasy X-2 lags on magic animations and i usually have 35 fps.

Final Fantasy XII Very Slow.

Is runing from an ISO faster then running from a DvD?

Sponsored links

There isn't any reason FFX or kingdom hearts to be running that slow on your machine because of your CPU... If I had to guess at a glance, it's your GPU causing the most slowdowns...

On your PCSX2 window when the games slowdown is the CPU % at or above 90%? (again, PCSX2 window, NOT in the task manager) If so, your GPU is definitely causing the problem. Make sure to update your PCSX2 to beta revision 1888, turn off 8-bit textures in the GSDX menu, and use the native res option. You may also try the speed hack VU cycle steal, but that may cause as much slowdown as it fixes.
[Image: 2748844.png]
During the slowdowns the CPU in pcsx window is 95% all other times is at arround 65% i tried the first Speed hack and the native minus the 8 bit textures and now i can play the FFX, FFX-2 and so on.

Kingdom hearts 1,2 and Suikoden haven't yet tried them i will try and tell .

Final Fantasy XII stil is as slow a snail...
Then it's your GPU causing the slowdowns. Check 'native' in GSdx or use a lower internal res than the one you currently have set (or get a faster graphics card).
Which PCSX2 version are you using? The latest 1888 beta is quite faster than 0.9.6 so you might want to give that a try too
[Image: newsig.jpg]
Well the ff x-2 is stil kinda slow, 35 fps
ffxii is rocking at 60fps
but sometimes give bsods.
ffx is flying
suikoden III also 40fps.
idk for kindom hearts yet
Yep, your GPU is the culprit. You need a better GPU. You can get a nice one for around $100+ that should run most games pretty well. Like the Nvidia Geforce 9800GT or the Geforce 250.
Laptop: Apple MacBook Pro Retina 15' | Intel Core i7-4850HQ @ 2.3-3.5Ghz | Optimus Powered nVidia Geforce GT 750M (2GB GDDR5) + Intel Iris Pro Graphics | 16GB (2x8GB) DDR3 1600Mhz RAM | Intel HD Audio | Apple Magic Trackpad | Samsung 512GB PCI-E Based SSD |
Beta 1888 really improved the speed for me, as playing FF12.
However, this new GSdx doesn't have pixel shader selection option. This was the thing that would get me amazing graphics back on 0.9.6, using Pixel Shader 3. Is there a way to config it in this new graphics plugin?

I'm in this system: Q8200 - 8600GT 256mb - 2GB 800mhz
Currently using GSdx 1873 and beta 1888.

Edit: I think I've figured it out. Disabling native, I achieve some great graphics, and even good speeds, but CPU meter goes beyond 90% all the time... What to do now?
Try a lower D3D internal res.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Thanks for the tip, but, strangely, the game is running way too fast, actually. No matter the D3D internal res or native resolution I'm using.
Take a look, it's like it doesnt matter.

But I guess it's fine for now.
I've setted up internal default 1024x1024. Auto frameskipping with 60 limit and it seems to be smooth most of the time for now, just some graphical glitches here and there with some slowdown, which must be resulting from speedhacks. In these moments I can see CPU meter going up really.
That simply means that your graphics card can handle the extra load from the higher resolution fine..
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)