Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Music gets laggy with FPS drop
#1
When I play Mana Khemia 2, music plays fine, but when I open menu or talking "screen" appears, FPS drops to ~35 and music "hiccups"/"tears"/gets laggy for a second, then it goes normally.

I've tried similar actions mentioned in this thread http://forums.pcsx2.net/Thread-Mana-Khem...nu-in-game
* enabling the MTVU
* playing from an ISO
As for resolution it is already on "Native". I've tried "2x Native" and 1366x1366 custom resolution to no effect.
I've tried "async mix", but "tearing" is still there and I have an impressions that it became slightly worse.

Any assistance?

Some of my specs:
i5 4 core 2.67Ghz/4gb ram/2.8gb video ATI
Reply

Sponsored links

#2
youcould try setting SPU2x to async instead of timestretch
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(11-29-2016, 12:45 PM)jesalvein Wrote: youcould try setting SPU2x to async instead of timestretch

Isn't it the same thing, which I already tried?
Quote:I've tried "async mix", but "tearing" is still there and I have an impressions that it became slightly worse.
Reply
#4
aw, yeah. sorry about that.

What do the ee% & gs% say when you get slow down /sound crackling ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
(11-29-2016, 02:13 PM)jesalvein Wrote: aw, yeah. sorry about that.

What do the ee% & gs% say when you get slow down /sound crackling ?

ee% normally (idle) ~37-49%, during opening menu ~18-30%
gs% normally (idle) ~7-15%, during opening menu ~33-40%
Reply
#6
I have the game. So i can look into it. I know all the atelier games have audio issues and i'll see if i can figure it out i think it has something to do with the latency option but like i said ill look into it.

Where does it start lagging?
[Image: dy6224-5.png]
Reply
#7
So While testing I haven't completely eliminated it but settings latency to 20 will minimize a lot of the lag. tho setting it lower will cause the audio to skip constantly.


------

After further testing, setting to async with between 25-35 ms latency still has a tear in the audio but has next to no lag in the loading of menu or text. its the best you can do with current code for the spu.
------
After even further testing, Directsound, Catmull-Rom Interpolation, Async, at 20ish latency sounds right. tho the FPS dip is still there. But. Its the best I can do. And its better then default settings.
[Image: dy6224-5.png]
Reply
#8
(11-29-2016, 06:42 PM)rikimaruaxu Wrote: So While testing I haven't completely eliminated it but settings latency to 20 will minimize a lot of the lag. tho setting it lower will cause the audio to skip constantly.


------

After further testing, setting to async with between 25-35 ms latency still has a tear in the audio but has next to no lag in the loading of menu or text. its the best you can do with current code for the spu.
------
After even further testing, Directsound, Catmull-Rom Interpolation, Async, at 20ish latency sounds right. tho the FPS dip is still there. But. Its the best I can do. And its better then default settings.

I've tried it "Directsound, Catmull-Rom Interpolation, Async, at 20ish latency" and result is even worse for me. Music sounds somewhat slow with constant smaller tears or like with additional noise even while character is idle.

Catmull-Rom Interpolation was already set.
Setting Directsound instead of XAudio2 adds some kind of random, seldom taps-like noise.
Async makes gap/lag during opening menu slightly bigger with very fast tapping-like sound, so TimeStretch is better for me. It has gap/lag too, but I feel that it is slightly shorter and it is just silence instead of fast tapping-like noise.
Setting latency for 20, even for Async, makes music to partially tear even during simple idle playing. Increasing it to 30 removes this tearing, but gap/lag during opening menu still there.
Reply
#9
Huh.. then our sound cards require different settings then.. I tested mine through HDMI audio so it might be different for sound cards.. experiment between 20-30 to find one thats bearable to you. this has been an issue with all the Atelier project games. So other then trying to minimize it the only option is to play it on ps2 sadly
[Image: dy6224-5.png]
Reply
#10
(11-30-2016, 01:41 PM)rikimaruaxu Wrote: Huh.. then our sound cards require different settings then.. I tested mine through HDMI audio so it might be different for sound cards.. experiment between 20-30 to find one thats bearable to you. this has been an issue with all the Atelier project games. So other then trying to minimize it the only option is to play it on ps2 sadly

I see. I tried 20-30 and there is no noticeable differences, be it 20-30 or 100, only that at 20 music gets worse.
Thank you for trying to help.
Reply




Users browsing this thread: 1 Guest(s)