Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
My PCX2 0.9.8 Is Very Slow When Playing Games And I Don't Know Why?
#1
I have Windows 7 dual core processor 2.00GHz and 4.00gb ram. I can play PC games that look just as good as the Xbox 360, and PS3, so I don't know why my games are slow, and laggy with the pcx2. Is there anyone who knows how to fix this or can send me a link to somewhere that would help my situation? It would help out a lot since I am a noob to this, thanks in advance.
Reply

Sponsored links

#2
pcsx2 settings, gpu, games your trying to play?
Reply
#3
Dragon ball z budokai 3, and kingdom hearts.
Reply
#4
ok, so that's one of the 3 questions I asked. anw answer the other 2
Reply
#5
(05-22-2012, 10:08 AM)Saiki Wrote: ok, so that's one of the 3 questions I asked. anw answer the other 2

My PCX2 settings are on default, and I have NVIDIA GeForce GT 220 graphics.
Reply
#6
you'll need to use some speedhacks since both your CPU & GPU are very weak for pcsx2
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#7
(05-22-2012, 08:08 AM)2crazynate Wrote: I can play PC games that look just as good as the Xbox 360, and PS3

Great.

For the answer, your computer is slow for pcsx2, read some optimizing guide or the official manual to play with the setting, just don't expect miracle.
Reply
#8
Set the internal resolution of the GS plugin to "Native".

Gradually apply more Speedhacks.

Try your other games if that doesn't run nearly fast enough.
Reply




Users browsing this thread: 1 Guest(s)