Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
My game ISO's makes my pcsx2 got lagged
#1
Hi all!

I buy Suikoden III dvd games, then I play it in pcsx2 on my LAPTOP, but sadly, my laptop's dvd-room shortly after I insert that dvd got noisy. I panic so I decided to download imgburn and get ISO from that. But when I use ISO, the pcsx2 runs lag. What is causing this? Is someone know? Help me please..
Reply

Sponsored links

#2
The probably reason is the machine being slow. Still there is a chance to enhance performance but we can tell you what to expect only if we know what to expect, so please inform the machine specs, like the CPU brand/model/speed and the GPU used in the laptop.

To advance things, most laptops will need a fair amount of speedhacks to ever hope to run the games at acceptable speed, but that's not granted for older or weaker models.
Imagination is where we are truly real
Reply
#3
I have CPUZ a program that explain (not much) my laptop specs, but I don't know how to explain...
Reply
#4
Here is my machine specs :

OS: Windows 7 Ultimate 32-bit (6. 1, Build 7600)
System Model: Satellite L740
Processor: Intel® Core™ i3 CPU M 380 @ 2.53GHz (4CPUs), ~2.5Ghz
Memory: DDR3 2048MB RAM
Chip Type: Intel® HD Graphics (Core i3)

That's all...
Reply
#5
That machine should get you playable speed but you may need to push the EE cyclerate speedhack to 2 and VU cycle stealing to 2 as well (both at around the center point). You may still get slowdown in some points and may want to use different combination of speedhacks. Just remember the least speedhack the better. Find the optimal point.

The greater problem in this case is the nowadays HD internal video is not good enough and you may want to keep the resolution at native.
Imagination is where we are truly real
Reply
#6
I've done it completely, but still I got the lag. You know, the screen when I play the game is stopping and playing and stopping and playing, just like you watch a movie and you pause then resume and you pause then resume and so on...
Reply
#7
I can't really help beyond this point for lack of experience with laptops, but there is one last suggestion, go to Power Options at the Windows control panel and set it to "Performance", remember to return it to the current plan afterwards to spare battery.
Imagination is where we are truly real
Reply
#8
It can't help either, I still got the lag Sad
Oh God..

Ok, it's Ok, maybe I should buy new laptop with supporting specs to play this PCSX2...
Reply
#9
Did it lag when you played from the dvd?
| CPU: i7 3820 @ 4,3GHz | Cooler: Corsair H100 (Noctua fans) | Kingston 16Gb 1833MHz quad channel |
| GPU(s): 2x Gigabyte R9 290 OC Windforce | MB: Asus P9X79 | Kingston HyperX 128Gb SSD, storage: 2x Seagate Barracuda 1Tb 7200rpm raid 0, Seagate Barracuda 1Tb 7200rpm |
| PSU: Corsair AX860i | Display: Asus 27" PB278Q, Asus 24" VE247H | OS: Win7 64bit |
Reply
#10
Sometimes, not as often as when I'm using ISO, bro. But when I played from dvd, the dvdrom of my laptop sounds so noisy, the sound is like car machine or something's more noisy. I got panic..
Reply




Users browsing this thread: 1 Guest(s)