Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
My god of war 2 is BLUE !
#1
Hello,

Happy new years all !

I have to report a strange visual bug with GOD of War 2 : when i launch the game all the colors turn to blue ones !
Here is a capture screen to explain : My bug
Strange no ?

I use the latest released of PCSX2
My configuration :

Intel Core I5 6500
Mother Board MSI B150 gaming M3
8 GB DDR4
MSI 970 GTX 4GB graphic card
Windows 10 (64 bits)
Latest official Nvidia driver

I use GSD 10 (directx 11)
3x resolution
FXAA & FX Shader enable
Texture Filtering enable
Anisotropic Filtering 8x on and the agressive CRC hack.
I try different values in my plugin settings with the same result.

Can you give me advice ?
Thanks
Reply

Sponsored links

#2
Get latest git build from here and use opengl. I would guess your gsdx settings are the issue so better use default ones for the beginning. Then only use upscaling.
Reply
#3
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#4
Here is the log :

PCSX2 1.2.1.r5873 - compiled on Feb  3 2014
Savestate version: 0x9a0a0000

Host Machine Init:
Operating System =  Microsoft  (build 9200), 64-bit
Physical RAM     =  8139 MB
CPU name         =  Intel® Core™ i5-6500 CPU @ 3.20GHz
Vendor/Model     =  GenuineIntel (stepping 03)
CPU speed        =  3.190 ghz (4 logical threads)
x86PType         =  Standard OEM
x86Flags         =  bfebfbff 7ffafbff
x86EFlags        =  2c100000

x86 Features Detected:
MMX.. SSE.. SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. FMA

Reserving memory for recompilers...

Loading plugins...
Binding   GS: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-avx2-r5875.dll 
Windows 6.2.9200
Binding  PAD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\lilypad-r5875.dll 
Binding SPU2: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\spu2-x-r5875.dll 
Binding CDVD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\cdvdGigaherz.dll 
(GameDB) 9655 games on record (loaded in 156ms)
Binding  USB: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\USBnull.dll 
Binding   FW: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\FWnull.dll 
Binding DEV9: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\DEV9null.dll 
Plugins loaded successfully.

HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 6.2.9200
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
* SPU2-X: Enumerating PortAudio devices:
 *** Device 0: 'Primary Sound Driver' (Windows DirectSound)
 *** Device 1: 'Speakers (Realtek High Definition Audio)' (Windows DirectSound)
 *** Device 2: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows DirectSound)
 *** Device 3: 'Speakers (Realtek High Definition Audio)' (Windows WASAPI)
 *** Device 4: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows WASAPI)
 *** Device 5: 'Speakers (Realtek HD Audio output)' (Windows WDM-KS)
 *** Device 6: 'SPDIF Out (Realtek HDA SPDIF Out)' (Windows WDM-KS)
Opening CDVD
isoFile open ok: E:\ROM\PS2\kds-gow2.iso
Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (2100912 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Corto\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Corto\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe  v02.00(14/06/2004)  Console
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.81;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_974.81;1) Game CRC = 0x2F123FD8, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.81;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
GSdx: failed to compile external post-processing shader. 
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Opening GS
Saving GS
Saving PAD
Saving SPU2
Saving CDVD
Saving USB
Saving FW
Saving DEV9
Shutting down plugins...
Plugins shutdown successfully.

Loading plugins...
Binding   GS: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\gsdx32-sse4-r5875.dll 
Windows 6.2.9200
Binding  PAD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\lilypad-r5875.dll 
Binding SPU2: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\spu2-x-r5875.dll 
Binding CDVD: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\cdvdGigaherz.dll 
Binding  USB: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\USBnull.dll 
Binding   FW: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\FWnull.dll 
Binding DEV9: C:\Program Files (x86)\PCSX2 1.2.1\Plugins\DEV9null.dll 
Plugins loaded successfully.


Initializing plugins...
Init GS
Windows 6.2.9200
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

EE/iR5900-32 Recompiler Reset
Opening GS
Loading GS
Loading PAD
Loading SPU2
Loading CDVD
Loading USB
Loading FW
Loading DEV9
Opening plugins...
Opening PAD
Opening SPU2
* SPU2-X: Enumerating PortAudio devices:
 *** Device 0: 'Primary Sound Driver' (Windows DirectSound)
 *** Device 1: 'Speakers (Realtek High Definition Audio)' (Windows DirectSound)
 *** Device 2: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows DirectSound)
 *** Device 3: 'Speakers (Realtek High Definition Audio)' (Windows WASAPI)
 *** Device 4: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows WASAPI)
 *** Device 5: 'Speakers (Realtek HD Audio output)' (Windows WDM-KS)
 *** Device 6: 'SPDIF Out (Realtek HDA SPDIF Out)' (Windows WDM-KS)
Opening CDVD
isoFile open ok: E:\ROM\PS2\kds-gow2.iso
Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (2100912 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Corto\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Corto\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
GSdx: failed to compile external post-processing shader. 
 > Selected savestate slot 0
Loading savestate from slot 0...
filename: C:\Users\Corto\Documents\PCSX2\sstates\SCUS-97481 (2F123FD8).00.p2s
EE/iR5900-32 Recompiler Reset
Loading GS
Loading PAD
Loading SPU2

Warning: BIOS Version Mismatch, savestate may be unstable!
Current BIOS:   Europe  v02.00(14/06/2004)  Console (crc=0x9c7b59d3)
Savestate BIOS: Europe  v01.60(04/10/2001)  Console (crc=0xb8e26e89)

[14:09:26.460] Auto-ejecting memcard [port:0, slot:0]
[14:09:26.523] Auto-ejecting memcard [port:1, slot:0]
[14:09:29.589] Re-inserting auto-ejected memcard [port:0, slot:0]
[14:09:30.085] Re-inserting auto-ejected memcard [port:1, slot:0]
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
HLE Notice: ELF does not have a path.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
* SPU2-X: Enumerating PortAudio devices:
 *** Device 0: 'Primary Sound Driver' (Windows DirectSound)
 *** Device 1: 'Speakers (Realtek High Definition Audio)' (Windows DirectSound)
 *** Device 2: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows DirectSound)
 *** Device 3: 'Speakers (Realtek High Definition Audio)' (Windows WASAPI)
 *** Device 4: 'Realtek Digital Output (Realtek High Definition Audio)' (Windows WASAPI)
 *** Device 5: 'Speakers (Realtek HD Audio output)' (Windows WDM-KS)
 *** Device 6: 'SPDIF Out (Realtek HDA SPDIF Out)' (Windows WDM-KS)
Opening CDVD
isoFile open ok: E:\ROM\PS2\kds-gow2.iso
Image type  = DVD
 * CDVD Disk Open: DVD, Single layer or unknown:
 * * Track 1: Data (Mode 1) (2100912 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0: C:\Users\Corto\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1: C:\Users\Corto\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe  v02.00(14/06/2004)  Console
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.81;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
ELF (cdrom0:\SCUS_974.81;1) Game CRC = 0x2F123FD8, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SCUS_974.81;1
(SYSTEM.CNF) Software version = 1.01
(SYSTEM.CNF) Disc region type = NTSC
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50,00 fps
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59,94 fps
GSdx: failed to compile external post-processing shader. 
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Shutting down plugins...
Plugins shutdown successfully.
(GameDB) Unloading...
Reply
#5
a few things :

1 - how big is your iso ?
2 - Are you using full boot ? Because your console is EU while your game is US
3 - Are you using gsdx shaders ?
Quote:GSdx: failed to compile external post-processing shader.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
@Jesalvein
- My iso is 4 302 667 776 byte large.
- I use fast boot. I always use thise option with my other computer (win 7 64 bits, q9650, 5 Gb ,RAM 560 Ti) and it was ok with GOW2 no bug with directx11.
- i use FX shader but with this option turned off it's the same bug.

@Willkuer : the exe won't launch. I've installed the visual basic 2013 but have a VCRUNTIME140.dll is missing message....
Reply
#7
Quote:- I use fast boot. I always use thise option with my other computer (win 7 64 bits, q9650, 5 Gb ,RAM 560 Ti) and it was ok with GOW2 no bug with directx11.


bug is not present at D3D11 ? then at which renderer is the bug present ?

Quote:@Willkuer : the exe won't launch. I've installed the visual basic 2013 but have a VCRUNTIME140.dll is missing message....

you need VS2015 redistributables for the latest development build as they're compiled using VS2015. ( specifically the 32 bit one)
Reply
#8
(01-05-2016, 03:34 PM)Celticstorm67 Wrote: @Jesalvein
- My iso is 4 302 667 776 byte large.

i suggest you redump it. you probably missed 1 layer.
try again with your original DVD

Quote:- I use fast boot. I always use thise option with my other computer (win 7 64 bits, q9650, 5 Gb ,RAM 560 Ti) and it was ok with GOW2 no bug with directx11.
still, best would be to reset settings, and then enable enhancements 1 by 1
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#9
O my god i've found the culprit...

When i try the pcsx2 version linked by Willkuer the colors in Dx11 were finaly ok.
But...but when i use upscaling option (2x,3x, custom...) the colors became blue !
I tested it with the official PCSX2 and it's the same. The culprit is the upscaling option in DX11 !

The Dx9 plugin appears to fully work but i've read that he isn't as good as the Dx11 one ?
Reply
#10
OGL on latest git is your best option.
Reply




Users browsing this thread: 1 Guest(s)