Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Nascar Issues
#1
Hi,
Love your program, never thought I'd be playing PS2 games on the computer! Laugh

First off, I'm a noob at this, I just installed it yesterday to play my favorite Nascar games from PS2:

Nascar Thunder 2004
Nascar 2005 Chase for the Cup.

But there's 2 game breaking problems I'm having, and I don't have a first clue on how to fix them Sad

For Nascar 2005 Chase for the Cup, the Car textures are missing! I only see the tires and driver, but ALL cars are like gray "shells" with no textures. (Although they have textures in the selection screen Tongue)

And for Nascar Thunder 2004, every time I load Bristol, as it finishes loading, the program stops responding. (And GS goes to 98-100% for some reason)
Other than that, everything else is good (I had flickering but that was fixed by pressing F5)

I don't get how to fix these, I really want to play these games, but it's unplayable without textures in 2005, or Bristol Speedway in 2004. Tongue
Is there ANYTHIHNG I can do? Hacks? Settings???

Btw, I already tried software mode (both dx9 and dx11) but both games just crash from F9. If I set it to software before launching, both games just crash right after boot.


I heard you need a powerful computer to run this....I have a custom build I built a year ago, is it not powerful enough to run this???
Here's my specs:

CPU: Intel i7 2700K Quad Core OC @4.8GHz
GPU: 2X Nvidia GTX 670 2GB SLI
Memory: 16 GB 2133 Dual Channel
Hard Drives: ADATA 120 GB SSD (boot drive) + 1 TB 7200 rpm + 500 GB 7200 rpm + 2 TB 5900RPM (all SATAs)
ASROCK Fatal1ty Motherboard
Titanium Sound card
3X 1080p monitors (I use Nvidia surround 3D)
The CPU is on air but it stays pretty cool (CoolerMaster Hyper 212 Heatsink) and 12 Case fans for airflow.

I'm using the latest build of PCSX2 (build 5710)

Thanks! And again great job with the program! I really love it and the Nascar Thunder games...
Reply

Sponsored links

#2
Anyone?
Reply
#3
This is a forum, not a chatroom. Everyone who posts help here are volunteers from all over the world from differing time zones... it can sometimes take several hours to get any responses, don't take it as a sign of being ignored.

#1: For the textures missing, have you tried playing in software mode and see if that fixes it? (edit) whoops, see you tried software mode, but software mode is crashing? That's a different issue you shouldn't be having...

#2: Does the sound freeze? Or is it just a black screen with the music playing? Or absolutely nothing? If the former, first try disabling all available speed hacks that may be on. Afterwards test (one at a time) the different special game hacks available as one of those may fix it.
[Image: 2748844.png]
Reply
#4
Sorry about that, I'll be more patient next time...
#1: I don't know what to do about it...

#2: The whole program (PCSX2) hangs and stops responding, and I have to restart it to get it working again (the whole program, not just the game).
Bristol loads, like normal, then right at the end of loading, before the leaving loading screen, the program hangs.
Tried it with and without ALL hacks, enable/disabled. Also tried them one at a time, still nothing.
Reply
#5
Hmm... interesting, I don't have the games on me so I can't test myself... all I can do is give suggestions.

Not sure what would be causing the lack of textures unless you're using MSAA. If you haven't already, you should also try disabling one of your graphics cards since SLI doesn't work with PCSX2 and just having it on can cause all sorts of graphical issues.

As for the crashing, you can try using SuperVU instead of MicroVU. You can also try disabling dual core mode in the same options menu (just to see if the off chance there is a problem there). Those aren't permanent solutions, but if there is an emulation related bug that might help track them down.
[Image: 2748844.png]
Reply
#6
Tried those, but none of them work either. (Where's MicroVU???)

I also saw a bug report thread for the Bristol Hang, but no replies or ideas on how it could be fixed Sad
Nascar 09 seems to also have the bugs (saw it on another thread too.) So this is definitely something with the emulation.

Edit: Nevermind, I found the SuperVU option.
Trying Nascar 2005 as I type this right now...
NOPE, textures still missingSad
Reply
#7
Okay, the best thing to do now then is to make a proper bug report in the bug reporting forum here: http://forums.pcsx2.net/Forum-Bug-reporting

Just make sure to write up your report following this template: http://forums.pcsx2.net/Thread-Sticky-Ho...RE-posting

Or you can post your bug report here as well: http://code.google.com/p/pcsx2/issues/list

Either one of those will work as the developers check them often. You were right to post in here first, but since we can probably safely assume that this is a proper emulation bug and not a bad setting, they'll be able to check the problem from those spots.
[Image: 2748844.png]
Reply




Users browsing this thread: 1 Guest(s)