Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need Help with Optimal Settings For Kingdom Hearts 2 FM (PcsX2 1.0.0)
#1
Hello everyone,

I've used the emulator before on a laptop and my lappy wasnt able to handle games that well, but now I have a great desktop that was able to handle Kingdom Hearts 1 with no problems (and I didn't need to adjust anything). Now I'm having some problems with Kingdom Hearts 2 Final Mix (particularly at cutscenes)

Here are my specs

-> Windows 7 64bit.
-> Processor: i5 4670 ( not K series, locked at 3.4 ghz)
-> Graphics Card: NVIDIA GTX 760
-> RAM: 8GB

Currently I adjusted the sound plugin to 0 (fastest/bad quality) and I have PCSX ad 4x native (I can play at 6x but I lowered it because I thought that was the reason for my fps drops, but it turns out that even at 4x native the cutscenes slow down a bit).

I also adjusted the Emulation Settings (in the GS section/Framelimiting area) as follows:

Base Framerate Adjust: 100%
Slow Motion Adjust: 1000%
Turbo Adjust: 1000%

Lastly under the speed hacks section I enabled MTVU (since my processor is quad core).

Anyway that's what I've done to my emulator. Can you guys help me with my FPS problem? I've also noticed that in some youtube videos people are able to get their fps between 60-100 while mine levels off at 60-62 and just hovers between 58-60 most of the time. Is that a good idea or should I try to get between 60-100 and how can I adjust it?

TL;DR what are the best settings for Kingdom Hearts 2 Final Mix for my specs? Main problem is that the fps drops to 40/37 at some cutscenes and in some parts of cutscenes.

Thanks in advance!
Reply

Sponsored links

#2
60fps is full speed. 90fps would make the game run 1.5x faster than normal speed. Also update to 1.2.1 and get rid of 1.0.0
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#3
(06-16-2014, 06:38 PM)Nobbs66 Wrote: 60fps is full speed. 90fps would make the game run 1.5x faster than normal speed. Also update to 1.2.1 and get rid of 1.0.0

Wouldnt I lose my save states? =/ I still got a couple states that I wanna clear.
Reply
#4
Why don't you just save to your memory card instead. SaveStates aren't recommended due to them saving any glitches that may occur.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#5
(06-16-2014, 06:57 PM)Nobbs66 Wrote: Why don't you just save to your memory card instead. SaveStates aren't recommended due to them saving any glitches that may occur.

Eh, sometimes I fluke and manage to do a large amount of damage to boss while still having my health bar up there and not blowing my items, so starting from there is easier than trying to whole fight all over again. So that's the advantage to me for using save states. Also helps if your computer randomly shuts off. But um yeah, I'll update the client in a couple hours then so I can get more detailed feedback for settings, thanks!
Reply
#6
It's fine using save states, just make sure to use memcards as well. It's not often, but sometimes it happens that a save state is bad. If that's all you've got then you would be starting over!
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#7
(06-16-2014, 09:02 PM)Blyss Sarania Wrote: It's fine using save states, just make sure to use memcards as well. It's not often, but sometimes it happens that a save state is bad. If that's all you've got then you would be starting over!

Especially when doing this :
Quote:Lastly under the speed hacks section I enabled MTVU (since my processor is quad core).
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
If you do wind up with a bad state, don't forget that your last state is backed up before it's overwritten. So you always have the last two you made. Which is good, I've had to use it a couple times. Only once or twice because of bad state, but a few times because I saved like .5 seconds before death on accident, and had no way forward lol.
[Image: ov4]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#9
Because it wasnt mentioned so far:

(06-16-2014, 06:15 PM)U_Menace Wrote: I also adjusted the Emulation Settings (in the GS section/Framelimiting area) as follows:

Base Framerate Adjust: 100%
Slow Motion Adjust: 1000%
Turbo Adjust: 1000%

This change doesn't help at all. The base framerate should always be 100% otherwise you would lose timing and create some bugs.

Turbo (Slow-Mo) can be toggled by tab (shift+tab) to change the speed of the game(including fps, gameplay speed, sound). 1000% will probably never work and it is reasonless to set the slow-mo rate to that value. Better keep using 50% and 200% (half and double speed). These are hacks to accelerate boring scenes or make hard bosses easier.


Regarding your problem:
Have you tried other speedhacks as well (especially the other tick-boxes)? Do you use non-default settings in emulation settings (EE, VU0/VU1,..)?
What are the GS% and EE% readings during slowdowns? (can be seen in the titlebar in windowed mode)
Do the lags only appear in fmv and that happens instantaneously? Or does it happen after some seconds? Are the slowdowns dependent on the shown content?
Are automatic gamefixes enabled? What happens if you disable them?
Reply
#10
(06-17-2014, 12:12 AM)willkuer Wrote: Because it wasnt mentioned so far:


This change doesn't help at all. The base framerate should always be 100% otherwise you would lose timing and create some bugs.

Turbo (Slow-Mo) can be toggled by tab (shift+tab) to change the speed of the game(including fps, gameplay speed, sound). 1000% will probably never work and it is reasonless to set the slow-mo rate to that value. Better keep using 50% and 200% (half and double speed). These are hacks to accelerate boring scenes or make hard bosses easier.


Regarding your problem:
Have you tried other speedhacks as well (especially the other tick-boxes)? Do you use non-default settings in emulation settings (EE, VU0/VU1,..)?
What are the GS% and EE% readings during slowdowns? (can be seen in the titlebar in windowed mode)
Do the lags only appear in fmv and that happens instantaneously? Or does it happen after some seconds? Are the slowdowns dependent on the shown content?
Are automatic gamefixes enabled? What happens if you disable them?

Okay so I haven't tried the other speedhacks except the ones with 'recommended' on them. I leave those on. Also the other settings in emulation are set to their defaults. As for the GS/EE% readings, I'll get back to you on that since I haven't hit another laggy scene yet.

Also, yes lag only happens during certain bits of cutscenes, but nothing particularly draining is happening. Sometimes a death animation gets a bit slow but aside from that I dont see why the game would be slower in certain areas over others.
Reply




Users browsing this thread: 1 Guest(s)