Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need a Boost In Software Mode (R&C3)
#1
Trying to run Ratchet & Clank 3 on my new PC. When using the graphics card (Hardware renderer) it runs at full speed, but naturally because of the mipmapping, the textures become buggy unless I get close to them. I want the game to look good, so I've switched to the software renderer.

Problem is that, no matter what I do and how fast I get it, some parts have heavy lag. The EE maxs out quickly when it gets to a laggy area, whereas GS is only around 50% in the laggy bits, VU about 30% and UI is always under 10%. The FPS takes a hit and goes down to about 41FPS.

My system specs:

CPU: Intel Core i7-3610QM @ 2.3GHz (8 cores; quad-core hyperthreaded)
Graphics Card: nVIDIA GeForce GT 630M
Memory: 8GBs DDR3 (1600MHz SDRAM)

Note that this is a laptop, and I think the fact that it is a laptop and the clock speed are both contributing factors to the problem.

PSCX2 Settings (Version 1.0):
Emulation Settings:
  • EE/IOP and VUs both have Clamping Mode set to "None"
  • Default to Fullscreen is Checked
  • All speedhacks, with exception to the sliders (they're set to the default), are checked.
GSdx 5334 Settings:
  • Using AVX (I heard it was better with the software renderer)
  • Renderer: DX11 (Software)
  • Interlacing currently set to "Auto", no visible performance hit
  • Extra Rendering Threads: 6 (The best performance I found through testing)
SPU2-X 5324 Settings:
  • Interpolation 0
  • Disable Effects Processing Checked
  • Module 0
  • Synchronizing Mode None
  • Audio Expansion None

Everything else (apart from my controller setup in Lillypad) is default. When graphics are right, I'll put the sound back on.

Anything I can conceivably do to get a speed up? Using the sliders in the speed hacks sections only seems to make the game run slower.
Reply

Sponsored links

#2
hey first try to set affinity on on core 0 and core 2 and core 4 and core 6 to be used instead of the 8 cores


second enable SW threaded mode to "2" or "3" when MTVU is disabled ...

Config < Video < Plugin settings < Extra rendering threads
Reply
#3
(08-07-2012, 03:38 AM)abdo123 Wrote: hey first try to set affinity on on core 0 and core 2 and core 4 and core 6 to be used instead of the 8 cores


second enable SW threaded mode to "2" or "3" when MTVU is disabled ...

Config < Video < Plugin settings < Extra rendering threads
Attempted both separately and at the same time, and the FPS got halved even on the non-laggy bits in all cases. Thanks, but no cigar.
Reply
#4
well you need to Disable HT ( that what i was worry about )

Does your Lap's BIOS offer such a thing ? ( usually it don't )
Reply
#5
(08-07-2012, 05:54 AM)abdo123 Wrote: well you need to Disable HT ( that what i was worry about )

Does your Lap's BIOS offer such a thing ? ( usually it don't )
Nope, it's even more basic that my original Dell Dimension 8400. The most I can do is change date, time and a couple security things.
Reply
#6
well SW mode is slow you have to deal with it

it's not like a bug more than a Feature ....

well that's the cost of accuracy Smile
Reply
#7
(08-07-2012, 08:05 AM)abdo123 Wrote: well SW mode is slow you have to deal with it

it's not like a bug more than a Feature ....

well that's the cost of accuracy Smile
Yeah, I was worried that would be the answer, but it's okay. The lag isn't TOO bad (only 9-10 frames slower at times), so I can live with it till I get a computer with a more powerful CPU (an actual desktop).

Thanks anyways.
Reply




Users browsing this thread: 1 Guest(s)