Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need for Speed: Most Wanted Unplayable. Any advise?
#1
Hello,

yesterday I wanted to play Need for Speed: Most Wanted on PCSX2, but unfortunately, it is unplayable. I already played Burnout 3: Takedown without any problems or lags and my PC should be powerful enough to handle PCSX2 (Hardware specs listed below)

If I run PCSX2 on any GS Hardware Mode (Both AVX and AVX2, the other versions only give me blackscreen), there are vertical stripes on the screen (see picture below). They are only shown ingame, when I'm driving. On Software mode, the game is encountering consistently low framerate, mostly around 50%.

I tried several versions of the game out (also the Black Edition), but in every version I've got the same problem. I really hope, somebody can help me out.

My hardware:
CPU: Intel i7 7700k OC 5,0Ghz
GPU: NVidia Geforce GTX 960
RAM: 8GB 3000MHz DDR4


Attached Files Thumbnail(s)
   
Reply

Sponsored links

#2
Try using OpenGL Hardware as your renderer, you might also need blending accuracy on at least basic. You might also need a newer Git version if you're on 1.4.0 Tongue
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(06-09-2017, 05:29 PM)refraction Wrote: Try using OpenGL Hardware as your renderer, you might also need blending accuracy on at least basic. You might also need a newer Git version if you're on 1.4.0 Tongue

How do I update my Git version and which Git version should I take?
Reply
#4
Just grab the download link nearest the top in the list and extract it over the top of your existing install of PCSX2 (I recommend deleting the plugins folder first to make sure you don't accidentally get left with an old plugin) then run it, simple as that Smile

You might need to delete the "portable.ini" file also if you didn't have one before, otherwise it will want to completely reconfigure.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
(06-09-2017, 08:58 PM)refraction Wrote: Just grab the download link nearest the top in the list and extract it over the top of your existing install of PCSX2 (I recommend deleting the plugins folder first to make sure you don't accidentally get left with an old plugin) then run it, simple as that Smile

You might need to delete the "portable.ini" file also if you didn't have one before, otherwise it will want to completely reconfigure.

With the 1.5.0 Git version it worked, thank you very much!
Reply
#6
No problem Smile
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)