Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need for Speed Underground 2 kills my system LOL
#1
I tried this twice and don't want to touch it again. I tried starting a carrier mode game. A brand new game and it plays the cutscene fine but after it tries to load the next par. This is when everything goes to s***. The emulator freezes up then my system freezes up along with or its moving at an INSANELY slow speed. I had to hard shutdown my system twice cause of this. I never thought I would see a game that kills the emulator so much that it kills my system along with it. Its quite funny if you think about it but at the same time its like WTF.

I tried this on the stable version 1.0.0 as well as 1.1.0 5674. Both play exactly the same with the same exact problems. Even on my system play on software or hardware mode at native PS2 res I get the same slowdowns. When you go to carrier mode option and when it loads up the car BAM I'm down to 28fps from 60 just like that.

Mods have stated its playable but from where I site I do not call this being playable. Maybe the mods on the compatibility thread that posted share different opinions on what playable actually means but this is just crazy.

I really do not know what more to say but a game screwing up the emulator so much that it forces me to hard shutdown my system is just WOW. I would never have thought to see a game that will break the emulator then break my system along with it LOL.

I say take this game off the playable list but that's just me. And one more thing How is this playable if this is what happening to me?

For the record. My specs...

15 3570 4.5ghz
2GB 6950
8GB 1.6ghz RAM
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply

Sponsored links

#2
Yes this game should be in unplayable list
it's not playable in pcsx2 at all
i tried this game some time ago
it run fine in starting intro
but when it goes in game
it slows down to 20-25 fps
i tried all possible seetings with it
but it's just s***
then i gave up on this game Sad
Reply
#3
Could you start a new carrier in it? could you get past the first cut scene after you do a new carrier?
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply
#4
(07-06-2013, 09:28 PM)fade2black001 Wrote: ...

I tried this on the stable version 1.0.0 as well as 1.1.0 5674. Both play exactly the same with the same exact problems. ...

Hmmm..
Try going in the other direction.
I know I've played it keeping close to 60fps with Software mode in the past, and you've got the right CPU for best results. Not sure what the status is anymore. It was never easy with this game, though.

I'd figure somewhere in the 0.9.7 to 0.9.8 area (r3113 to r4600).
Reply
#5
COME ON. screw this. the NFS games have nicely running native PC versions. why bother trying to make that run on emulation?

f*ck you... spend your pennies. Tongue
Reply
#6
(07-07-2013, 02:15 AM)xstyla Wrote: f*ck you... spend your pennies. Tongue

Lmao. Best quote ever lol.
[Image: jmt41l-2.png]
SSD: 250GB | HDD: 2TB | GPU: MSI GTX 970 4G Gaming
Reply
#7
(07-06-2013, 09:41 PM)fade2black001 Wrote: Could you start a new carrier in it? could you get past the first cut scene after you do a new carrier?


i think it was only underground that i have
is it say Go Underground in first place ?
Reply
#8
(07-07-2013, 12:35 AM)Rezard Wrote: Hmmm..
Try going in the other direction.
I know I've played it keeping close to 60fps with Software mode in the past, and you've got the right CPU for best results. Not sure what the status is anymore. It was never easy with this game, though.

I'd figure somewhere in the 0.9.7 to 0.9.8 area (r3113 to r4600).

You and you 4.9GHZ CPU.... I can not get 60 fps on my CPU in software mode. My GS is at 100% and my EE% is at an average of 52%. My FPS drops down to as low as 38 and gets as high as 49 but I never seen 50. If a car passes my it drops a lot. Its more playable on .9.8 but its really slow even on my system..
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply
#9
The GS% will always max out in SW mode due to CPU doing all the gpu and work. So try setting extra SW rendering threads to 3 to see if GS % can be lowered and have better fps.
OS: Linux Mint 17.2 64 bit (occasional Antergos/Arch user)
(I am no longer a Windows user)
CPU: Intel Pentium G3258
GPU: Nvidia GTX 650 Ti



Reply
#10
My threads are set to 16... Just for the hell of it...

I figured it out. I set EE cylerate and VU cyle steal to 3 and I get a stead 60 fps at all times now. But the audio is screwed up lol. Its has a lot of static in it.
I5 3570k 3.4ghz| 4GB R9 290| 8GB DDR3
Reply




Users browsing this thread: 1 Guest(s)