Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need help getting PCSX2 to work properly please help!
#1
I have the Asus u30J laptop computer. I managed to get the pcsx2 up and running to play Final Fantasy X, but there are parts in the game where the FPS drops from about 55 to like 20. This usually happens when spells are cast or just in battle in general. I'm wondering if anybody knows the configuration to help maximize the gameplay? Thanks! Oh, i should mention that i am using the PCSX2 version 0.9.7

Asus U30J specs
Intel Core i3-350M @ 2.26GHz, 1066MHz FSB; 3MB L3 Cache
4GB of DDR3 RAM (1066MHz; 2x2GB)
NVIDIA GeForce GT 310M (512MB) + Intel GMA graphics
Reply

Sponsored links

#2
You can't do anything about it.usually in rpg games magic takes a lot of graphic power because of PixelShader effects like blur or others.and it takes a lot of cpu power.ffx lags a bit on ps2.don't bother trying to fix it. Smile
Reply
#3
oh i see. Well, if there is nothing i can do about it, then i guess it will just have to do. Thanks for telling me!
Reply
#4
The main cause is lack of speedhack or too many speedhacks. VU Cycle Stealing actually enhances FPS but may lag insufferably at some parts because less actual things are happening in the meantime that what should be happening (hence the stealing cycles in the name).

try playing with the speedhacks to achieve the best possible playability with less hacks as possible.
Imagination is where we are truly real
Reply
#5
ok i got to a part in the game where there were a lot of background graphics and my fps promptly tanked to about 10-15. I tried playing with the speedhacks, but it all was about the same. Is there anything that i can do?
Reply
#6
Unfortunately PCSX2 performance is almost directly linked to the speed of your processor with 3ghz+ being recommended for 3d games. You could try setting up frame skip, but that's just as likely to cause graphic glitches than anything else. You can also try changing the clamp options to none and using the legacy SuperVU instead of microVU which is often faster though less compatible (should work perfectly fine for FFX though)
[Image: 2748844.png]
Reply
#7
I think clamping mode none does make the game crash at some points actually, but it was a long time I played it so maybe its changed.

Edit: Just to clarify it was not random crashes, but at specific points in the game. Like the sending at kilika I thing didnt like clamping none.
Specs:
CPU: C2D E8400 @ 3.6
GPU: GTX 560Ti 2Gb
MOB: Asus P5QL
RAM: Crucial 4Gb
OS: Windows 7 64bit/XP 32bit
Reply
#8
That's just your computer specs. Like in any computer game you play, there are parts that will take a s*** load of CPU and GPU processing power. Your computer just can't handle it.
Reply




Users browsing this thread: 1 Guest(s)