Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need help speeding up Dark Cloud
#1
Hello,

I am trying to run Dark cloud(PAL version) on PCSX2 0.9.6, but it is so slow. Ingame I have an fps of 25-35 and 50fps in menus. Whatever I do I cannot manage to get more than 35 fps, I tried all speed hacks and they do not speed up anything.

It says that it uses 98% CPU even though task manager tells me only 53% of my CPU is used. In menus it only uses <12% CPU and task manager says that only 30% is used. So I assume this has something to do with a limit on my cpu?

Specs:
CPU: AMD Phenom 9650 Quad Core Processor 2.30GHz
RAM: 2GB RAM
GPU: Ati Radeon HD 4870 512MB Pixel Shader 4.1
OS: Windows XP Pro SP 3
Controller: XBOX360 Wireless

Configuration:
GSdx 890 (MSVC 15.00, SSE2) 0.1.14:
Windowed, Direct3D9(Hardware), Pixel Shader 3.0, Native, Texture Filtering on, Alpha correction (FBA) on
SPU2-X 1.1.0: Default settings
Controllers: LilyPad 0.9.9, only changed hotkeys for play.
Cdvdrom: Gigaherz's CDVD Plugin 0.7.0
Rest: Default


Thanks in Advance
Reply

Sponsored links

#2
hmm... i have it run almost perfect whenever i set the native resolution.
just the default, all speedhacks on, and nothing else actually...

and i "only" have a dualcore...

but if your using last beta, they did say it would run slower, maybe go back a beta version?

Damian666
Reply
#3
(06-10-2009, 03:45 PM)Damian666 Wrote: hmm... i have it run almost perfect whenever i set the native resolution.
just the default, all speedhacks on, and nothing else actually...

and i "only" have a dualcore...

but if your using last beta, they did say it would run slower, maybe go back a beta version?

Damian666
Native resolution or not, speedhacks on or off. Still 25-35 fps.

I am using 0.9.6 from the download section, as far as I know that is not the latest beta.
Reply
#4
ah, well... maybe you should try to go up some beta versions then?

if i am correct, it was slow for me too on normal 0.9.6

its worth a shot Smile

Damian666
Reply
#5
If i'm not wrong, dx10 would be a vast improvement over your current fps, however overclocking your cpu might seem the best option since it does utilise only 2 cores, which if you had the right cooling equipment is awesome! Never actually ran Dark Cloud 1 on PCSX2, only Dark Chronicle (Dark Cloud 2 Tongue)

Thats if you have fully experimented with all speed hacks, ect and get no real performance increase, hope this helps!
CPU: AMD Athlon 64 7750 x2 BE @ 3.2 Ghz
RAM: 4gb (2GB x2) Patriot Extreme Performance DDR2 800 (4,4,4,12)
Mobo: GA-M720-US3
Gfx: Radeon HD 4850 512mb GDDR3
Windows 7 RC x64
Reply
#6
Try downloading the newest Gdsx revision from here:
http://forums.pcsx2.net/thread-3031-page-1.html

As of 1322, there should have been a speed up for ATI cards
Reply
#7
(06-10-2009, 04:09 PM)Damian666 Wrote: ah, well... maybe you should try to go up some beta versions then?

if i am correct, it was slow for me too on normal 0.9.6

its worth a shot Smile

Damian666
I tried the beta and the plugins from 15 may. It didn't change a thing for me.

(06-10-2009, 08:01 PM)Makai_Neko Wrote: If i'm not wrong, dx10 would be a vast improvement over your current fps, however overclocking your cpu might seem the best option since it does utilise only 2 cores, which if you had the right cooling equipment is awesome! Never actually ran Dark Cloud 1 on PCSX2, only Dark Chronicle (Dark Cloud 2 Tongue)

Thats if you have fully experimented with all speed hacks, ect and get no real performance increase, hope this helps!

I don't have windows Vista, so I can't try DX10, but I will keep that in mind. I have the boxed cooler, so I rather not overclock it (yet).

(06-11-2009, 12:30 AM)Morkolds Wrote: Try downloading the newest Gdsx revision from here:
http://forums.pcsx2.net/thread-3031-page-1.html

As of 1322, there should have been a speed up for ATI cards

I tried and it really helped, made the fps rise to 39-43. Also with this version speed hacks actually work. With VUcycle stealing on full I get 50fps(full) and 40+ in some laggy scenes. I have to test it later to see if it runs on others settings and resolutions, also I need to test it to see if it will not break when playing for more than 5 minutes, but as it is now, it is playable.

Thanks to the three of you.
Reply
#8
wait, i downloaded the cdvd plugin, and it doesnt work for some reason, it says there was in error. how can this be fixed? and is there any specific info you need?

thanks so much for the time
Reply
#9
(06-23-2009, 03:43 PM)darkablo Wrote: wait, i downloaded the cdvd plugin, and it doesnt work for some reason, it says there was in error. how can this be fixed? and is there any specific info you need?

thanks so much for the time

Make your own thread,since you have a totally different problem...
[Image: newsig.jpg]
Reply
#10
when GS window show 98% of CPU used, and system monitor show 30% on quad core, it means that GS thread spam all core power for itself. I saw only two choices 1) you don't turn on MGTS mode and pcsx2 use only one core (1 core is 25% load), 2) you videocard doing something wrong, maybe bad videodrivers, or overheat.
Reply




Users browsing this thread: 1 Guest(s)