Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need help with Gran turismo 4 crashing
#1
Exclamation 
Hi everyone, i just registered to seek help to resolve a problem i have when i try to play GT4 on PCSX2.
The problem is that when i play using OpenGL (Hardware) PCSX2 crashes immediately. The menus are fine, but when i select a car or start a race the game crashes.
If i play using Direct3D11 everything works fine, but the ingame screen becomes very dark when i use 480p or 1080i mode.
And i have another problem, a graphic one. Whatever renderer i try, i always have some white/randomly colored lines on the side of the screen. (attached image)
I would like to still use OpenGL because of the fixed problem where, if the 480p or 1080i mode is used, the ingame screen becomes dark even in sunny conditions..

My specs are:

i5-6600K overclocked at 4.1Ghz;
Corsair Vengeance Ram, 16GB DDR4 3000Mhz;
MSI Z170 M3 motherboard;
Toshiba 1TB Hard disk;
Gigabyte GTX 1070, 8GB;
EVGA Supernova G2 750W;
Cooler master Masterbox case.
Windows 10 64bit.

I use PCSX2 1.5.0, the latest version.

Here there are the ONLY options i changed/selected.
EE/IOP - Clamping mode: Full (to fix the problem where car times doesn't appear)
GS Window - Aspect Ratio: 16:9
Speedhacks - MTVU (i even tried disabling this but it did not fix anything)

GSdx Settings are in the attached image.

Based on all the info i gave, does someone have an idea of what's causing this crash? Thanks in advance for every future reply  Smile


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
use one of the Native x# scaling modes and don't go above about x2 or x3 at a push, the game causes a massive memory leak so it'll crash as soon as you go ingame if you go any higher.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(07-17-2017, 07:23 PM)refraction Wrote: use one of the Native x# scaling modes and don't go above about x2 or x3 at a push, the game causes a massive memory leak so it'll crash as soon as you go ingame if you go any higher.
Thanks, it worked! But those lines on the side of the screen are still there, any idea how to fix it?
Reply
#4
Change the gs window size from 100 to 100.50℅
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply
#5
(07-17-2017, 09:19 PM)lightningterror Wrote: Change the gs window size from 100 to 100.50℅
Thanks guys, the game now works perfectly. Honestly when i was creating the thread i never imagined such a good and fast support. Thanks again.
Reply
#6
try increase the zoom by a few percent.
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Reply
#7
Also don't use 480p or 1080i mode. It doesn't matter since you're using hw mode with upscaling if I'm correct.

If it still looks a little darker try these shade options
Enable Shade boost
80 brightness
47 contrast
60 saturation

Also you can disable some of the options like mipmapping , large framebuffer. Aalso turn off hw hacks except TC offsets , I don't think you need them.
CPU: I3-4160 3.6GHZ
Motherboard: Asrock B85M - DGS
RAM: Hyper X Savage 2x8GB 1.6GHZ cl9
GPU: Asus AMD Radeon R7 360 OC 2GB GDDR5
OS: Windows 7 Ultimate SP1 64bit
Reply




Users browsing this thread: 1 Guest(s)