Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need some help, slow game and sound chopping on KH2
Hey all, I'm having some problems with KH2 with slow gameplay in-game and some sound chopping during the cinematic and after hours of searching for posts and guides and trying various things I've given up and I'm hoping that someone can tell me if it's my computer/game/my settings.

I have tried a mixture of both the CD and iso file with the same results.

Computer Specs:
Vista Home Premium 32-bit
2Gig RAM
GeForce 8400GS 512mb
AMD Athlon™ 64 X2 Dual Core Processor 4200+ ~2.2GHz

Settings Pcsx2:

GSdx 890 (MSVC 15.00, SSE2) 0.1.14
-Interlacing ~ None
-Aspec Ratio ~ 4:3
-D3D int. 1024/1024 (native uncheck)
-SW rend ~ 1 and gray
-NLOOP hack ~ checked but grey
-texture filtering ~ checked
-Alpha Correction ~ checked but gray
- everything else unchecked.

-Linuz Iso CDVD 0.8.0

-SPU2-X 1.1.0

-All 4 boxes checked, Vu Skip, 0 on all boxes.

Also, if it turns out to be a computer problem, will 2 gigs of ram help it? I have 2 gigs of ram on the way and I'm curious if ram increase the peformance of the game.


Sponsored links

Your CPU is a bit weak, your vid card also but it should be ok for this game. I'd recommend you to get the latest PCSX2 plublic beta and enable speedhacks from the "Config > Speed Hacks" menu, also try using 512x512 as D3D internal resolution in GSdx or ticking the "native" checkbox.

Adding Ram wouldnt help emulation speed, pcsx2 works great from 1Gb Ram.
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Thanks a lot Shadow Lady Smile! The gameplay is really smooth as if I were playing it on my PS2. The only thing a bit off is the voices sounding a bit robot-like but I can live with that. Thanks again!

Users browsing this thread: 1 Guest(s)