Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Neopets The Darkest Faerie; Having odd fogginess
#1
So... playing this kinda obscure old PS2 game, and I've been having two perplexing visual glitches. Or maybe three. I'm not entirely sure if two are the same or just highly similar.
http://prntscr.com/f2c2vp
Here's the first bug, though it seems to be fixed by setting "skipdraw" to 1.

http://prntscr.com/f2c3qf
http://prntscr.com/f2c438
Now here's the second, which might be a tad hard to see. Faint white borders around... well, many things, but especially particle effects. I'm unsure of how to fix this.
http://prntscr.com/f2c4ft
There is also... a faint fog-like layer in the distance, covering anything far enough away... but I honestly do not know if it was there originally(as in, pre-emulation), as I'm using a much higher quality screen than I did when I used to play it on a PS2.

Anyone who knows the system better able to offer some advice?
Reply

Sponsored links

#2
Don't use skipdraw to skip those lines, instead use OpenGL and set the Blending Accuracy to "Basic", I believe that solves the problem.

Not sure on the fog, but the above change might make it make more sense. Although this does ring a bell, I think somebody reported this recently.

Edit: Here it is, check this thread out http://forums.pcsx2.net/Thread-Screwy-fo...ht=neopets
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
Took a look, tried the fixed... and while OpenGL did get rid of the odd boxes around trees, the overly close fog seems to remain(and turning off skipdraw seems to have brought back the red lines, except for areas of the screen facing... the sky? There's some object that when viewed makes the lines vanish, oddly: http://prntscr.com/f2hcm8 ).
Fiddled with settings while writing this, and bumped skipdraw to 2 instead of 1 by mistake... and it actually seems to have fixed/removed the fog. Is there a downside to keeping it on?
Reply
#4
Did you change the blending accuracy when you turned skipdraw off?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
(04-30-2017, 11:45 AM)refraction Wrote: Did you change the blending accuracy when you turned skipdraw off?

Indeed. Tried Basic, Medium, and High, but none affected it(and given that high started to cause a frame rate drop, I doubt the higher ones would work well for me... especially given the odd but admittedly amusing quirk this game has with frame rate; the speed of EVERYTHING, even the music, is tied to frame rate. So a frame rate drop suddenly puts the music in slow motion because... reasons. Bumping fps above 60 instead makes everything go into super speed mode.).
Reply




Users browsing this thread: 1 Guest(s)